com.adobe.cq.sightly, version=[2.5,3) -- Cannot be resolved

amangoyal_15

14-02-2019

Hi everyone,

I am working on aem version upgrade from 6.2 to 6.4

I did inplace upgrade and getting one dependency issue

com.adobe.cq.sightly, version=[2.5,3) -- Cannot be resolved

I am using Uber jar v6.4 and also tried with import package statement for *com.adobe.cq.sightly:version=2.5.3

<Import-Package>

     com.adobe.cq.sightly;version="2.5.3",*

</Import-Package>

OR

<Import-Package>

     com.adobe.cq.sightly;resolution:=required;version="[2.5,3)",*

</Import-Package>

With /system/console/depfinder , I tried to check all dependencies of com.adobe.cq.sightly. below is the screenshot -Screenshot 2019-02-15 at 12.06.02 PM.png

Package Com.adobe.cq.sightly which is exported by com.adobe.cq.sightly.cq-wcm-sightly-extension is of version 3.2.0 but my bundle needs somewhere between 2.5 and 3

How can it be resolved?

Thanks.

Accepted Solutions (0)