Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

Certain images block replication queue with "Repository error during node import: Access denied" error

Avatar

Avatar
Validate 10
Level 3
anjali_biddanda
Level 3

Likes

17 likes

Total Posts

69 posts

Correct Reply

6 solutions
Top badges earned
Validate 10
Validate 1
Give Back 5
Give Back 3
Give Back
View profile

Avatar
Validate 10
Level 3
anjali_biddanda
Level 3

Likes

17 likes

Total Posts

69 posts

Correct Reply

6 solutions
Top badges earned
Validate 10
Validate 1
Give Back 5
Give Back 3
Give Back
View profile
anjali_biddanda
Level 3

15-10-2015

Replication queue cannot process remaining items in queue when an image replication fails with "Repository node import error: access denied” error.

This happens only with a few images, most get replicated. Could it be possible that it's these images are too big? We see a "HTTP/1.1 400 Bad Request" in the replication agent logs (pasted below).

------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

22.01.2015 15:45:37 - INFO - publish-c2cmsp-x01t : Replication (ACTIVATE) of /content/dam/images/entertainment/shows/c/call-the-midwife/callthemidwide_showcarousel.jpg not successful.
22.01.2015 15:46:34 - INFO - publish-c2cmsp-x01t : Sending POST request to http://c2cmsp-x01t:4503/bin/receive?sling:authRequestLogin=1
22.01.2015 15:46:34 - INFO - publish-c2cmsp-x01t : sent. Response: 400 Bad Request
22.01.2015 15:46:34 - ERROR - publish-c2cmsp-x01t : Replication (ACTIVATE) of /content/dam/images/entertainment/shows/c/call-the-midwife/callthemidwide_showcarousel.jpg not successful. Conversation follows
22.01.2015 15:46:34 - ERROR - publish-c2cmsp-x01t : ------------------------------------------------
22.01.2015 15:46:34 - ERROR - publish-c2cmsp-x01t : Sending message to c2cmsp-x01t:4503
22.01.2015 15:46:34 - ERROR - publish-c2cmsp-x01t : >> POST /bin/receive HTTP/1.0
22.01.2015 15:46:34 - ERROR - publish-c2cmsp-x01t : >> Action: Activate
22.01.2015 15:46:34 - ERROR - publish-c2cmsp-x01t : >> Path: /content/dam/images/entertainment/shows/c/call-the-midwife/callthemidwide_showcarousel.jpg
22.01.2015 15:46:34 - ERROR - publish-c2cmsp-x01t : >> Handle: /content/dam/images/entertainment/shows/c/call-the-midwife/callthemidwide_showcarousel.jpg
22.01.2015 15:46:34 - ERROR - publish-c2cmsp-x01t : >> Referer: about:blank
22.01.2015 15:46:34 - ERROR - publish-c2cmsp-x01t : >> ...spooling 16232931 bytes...
22.01.2015 15:46:34 - ERROR - publish-c2cmsp-x01t : --
22.01.2015 15:46:34 - ERROR - publish-c2cmsp-x01t : << HTTP/1.1 400 Bad Request
22.01.2015 15:46:34 - ERROR - publish-c2cmsp-x01t : << Connection: Close
22.01.2015 15:46:34 - ERROR - publish-c2cmsp-x01t : << Server: Day-Servlet-Engine/4.1.52
22.01.2015 15:46:34 - ERROR - publish-c2cmsp-x01t : << Content-Type: text/plain;charset=utf-8
22.01.2015 15:46:34 - ERROR - publish-c2cmsp-x01t : << Content-Length: 103
22.01.2015 15:46:34 - ERROR - publish-c2cmsp-x01t : << Date: Thu, 22 Jan 2015 02:46:34 GMT
22.01.2015 15:46:34 - ERROR - publish-c2cmsp-x01t : << s-maxage: 120
22.01.2015 15:46:34 - ERROR - publish-c2cmsp-x01t : << Cache-Control: no-cache, no-store, must-revalidate
22.01.2015 15:46:34 - ERROR - publish-c2cmsp-x01t : << 
22.01.2015 15:46:34 - ERROR - publish-c2cmsp-x01t : << error: com.day.cq.replication.ReplicationException: Repository error during node import: Access denied.
22.01.2015 15:46:34 - ERROR - publish-c2cmsp-x01t : Message sent.
22.01.2015 15:46:34 - ERROR - publish-c2cmsp-x01t : ------------------------------------------------
22.01.2015 15:46:34 - INFO - publish-c2cmsp-x01t : Replication (ACTIVATE) of /content/dam/images/entertainment/shows/c/call-the-midwife/callthemidwide_showcarousel.jpg not successful.
22.01.2015 15:47:34 - INFO - publish-c2cmsp-x01t : Sending POST request to http://c2cmsp-x01t:4503/bin/receive?sling:authRequestLogin=1
22.01.2015 15:47:35 - INFO - publish-c2cmsp-x01t : sent. Response: 400 Bad Request

 


This is the SAME ISSUE mentioned in the following ticket I found when searching the internet: https://forums.adobe.com/thread/1130975
But this was never answered.


Error.log extract from the publisher attached.

Attached is the image package. You need an Author and Publisher instances and configure the Default Publish Agent to use a different user (not admin) for transport user. This user (lets call it "replication-publisher" user) should exist on both author and publisher and should be given full access to everything under /content.

Then activate the image from damadmin. You'll see in the replication queue and you should see the "Repository error during node import: Access denied". Funnily enough, i could replicate it in my previous author-publisher instance, but not in a mode recent one. But this happens in all our environments for particular large images.

Please note that when you use 'admin' as transport user, the replication is successful. The permissions on the replication-publisher transport isn't the issue though - this user has full access to /content node on both author and publisher.

View Entire Topic

Avatar

Avatar
Validate 10
Level 3
anjali_biddanda
Level 3

Likes

17 likes

Total Posts

69 posts

Correct Reply

6 solutions
Top badges earned
Validate 10
Validate 1
Give Back 5
Give Back 3
Give Back
View profile

Avatar
Validate 10
Level 3
anjali_biddanda
Level 3

Likes

17 likes

Total Posts

69 posts

Correct Reply

6 solutions
Top badges earned
Validate 10
Validate 1
Give Back 5
Give Back 3
Give Back
View profile
anjali_biddanda
Level 3

15-10-2015

Thanks for taking the time to reply Sham. However, it only happens for 3-4 random images, all others replicate fine. 

p.s:We're using CQ5.6.1 which has a few replication bugs fixed since CQ5.5.