Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

Cannot sorting result for multiple path in AEM 6.3

Avatar

Avatar
Validate 1
Level 1
rayow4694015
Level 1

Likes

0 likes

Total Posts

4 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
View profile

Avatar
Validate 1
Level 1
rayow4694015
Level 1

Likes

0 likes

Total Posts

4 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
View profile
rayow4694015
Level 1

25-06-2019

Dear All

i need your help to solve my issue below. i have a query

type=cq:Page

group.1_path=/content/we-retail/us/en/experience

group.2_path=/content/we-retail/us/en/men

group.3_path=/content/we-retail/us/en/women

group.4_path=/content/we-retail/us/en/equipment

group.p.or=true

orderby=@jcr:created

p.limit=-1

when i click execute the error

java.text.ParseException: (/jcr:root/content/we-retail/us/en/experience//element(*, cq:Page) | /jcr:root/content/we-retail/us/en/men//element(*, cq:Page) | /jcr:root/content/we-retail/us/en/women//element(*, cq:Page))order by @jcr:created converted to SQL-2 Query: select [jcr:path], [jcr:score], * from [cq:Page] as a where isdescendantnode(a, '/content/we-retail/us/en/experience') /* xpath: /jcr:root/content/we-retail/us/en/experience//element(*, cq:Page) order by @jcr:created */ union select [jcr:path], [jcr:score], * from [cq:Page] as a where isdescendantnode(a, '/content/we-retail/us/en/men') /* xpath: /jcr:root/content/we-retail/us/en/men//element(*, cq:Page) order by @jcr:created */ order by [jcr:created] union(*)select [jcr:path], [jcr:score], * from [cq:Page] as a where isdescendantnode(a, '/content/we-retail/us/en/women') /* xpath: /jcr:root/content/we-retail/us/en/women//element(*, cq:Page)order by @jcr:created */ order by [jcr:created]; expected:

if i remove "group.3_path=/content/we-retail/us/en/women" and "group.4_path=/content/we-retail/us/en/equipment" from query it's working fine, any suggestion??

Execution Info:

N/A

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar
Validate 1
Level 3
Lavanya_Malyala
Level 3

Likes

20 likes

Total Posts

29 posts

Correct Reply

9 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 10
Boost 1
View profile

Avatar
Validate 1
Level 3
Lavanya_Malyala
Level 3

Likes

20 likes

Total Posts

29 posts

Correct Reply

9 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 10
Boost 1
View profile
Lavanya_Malyala
Level 3

25-06-2019

Hi,

I was able to reproduce your issue in AEM 6.3. However, I had installed SP 6.3.2 and re-ran the same query again. It worked for me after installing the service pack.

Please take a look at old forum question (same issue as yours) - https://forums.adobe.com/thread/2384937. They were able to resolve the issue after installing hotfix aem-6.3.0.

I hope this should resolve your issue as well.

Regards,

Lavanya Malyala

Answers (4)

Answers (4)

Avatar

Avatar
Coach
MVP
Arun_Patidar
MVP

Likes

1,358 likes

Total Posts

3,228 posts

Correct Reply

918 solutions
Top badges earned
Coach
Contributor 2
Ignite 10
Give Back 700
Boost 1000
View profile

Avatar
Coach
MVP
Arun_Patidar
MVP

Likes

1,358 likes

Total Posts

3,228 posts

Correct Reply

918 solutions
Top badges earned
Coach
Contributor 2
Ignite 10
Give Back 700
Boost 1000
View profile
Arun_Patidar
MVP

26-06-2019

Please try below query in 6.3

type=cq:Page

group.1_path=/content/we-retail/us/en/experience

group.1_path.self=true

group.2_path=/content/we-retail/us/en/men

group.2_path.self=true

group.3_path=/content/we-retail/us/en/women

group.3_path.self=true

group.4_path=/content/we-retail/us/en/equipment

group.4_path.self=true

group.p.or=true

orderby=@jcr:created

p.limit=-1

Avatar

Avatar
Validate 1
Level 1
rayow4694015
Level 1

Likes

0 likes

Total Posts

4 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
View profile

Avatar
Validate 1
Level 1
rayow4694015
Level 1

Likes

0 likes

Total Posts

4 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
View profile
rayow4694015
Level 1

26-06-2019

i have succesfully install but still any dependencies that could be installed, should i ignore it or i must find the package because when i click install the error message appear

1779761_pastedImage_0.png

Avatar

Avatar
Validate 1
Level 3
Lavanya_Malyala
Level 3

Likes

20 likes

Total Posts

29 posts

Correct Reply

9 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 10
Boost 1
View profile

Avatar
Validate 1
Level 3
Lavanya_Malyala
Level 3

Likes

20 likes

Total Posts

29 posts

Correct Reply

9 solutions
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 10
Boost 1
View profile
Lavanya_Malyala
Level 3

26-06-2019

It should ideally work for you as well. If not, do let me know. I'll be more than happy to help!

Regards,

Lavanya Malyala

Avatar

Avatar
Validate 1
Level 1
rayow4694015
Level 1

Likes

0 likes

Total Posts

4 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
View profile

Avatar
Validate 1
Level 1
rayow4694015
Level 1

Likes

0 likes

Total Posts

4 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
View profile
rayow4694015
Level 1

26-06-2019

Thanks for the answer lavanya

i'll try installed the higher one AEM Cumulative Fix Pack 6.3.3.4, hope it's works