Can not restore AEM instance.

chaud81156861

12-02-2019

Hi guys,

Recently, I usually found an issue with AEM 6.4 instances. Sometimes I can not start the instances because of the error as below:

*ERROR* [qtp1120022051-69] org.apache.sling.engine.impl.SlingHttpContext handleSecurity: AuthenticationSupport service missing. Cannot authenticate request.

We checked in the host:port/system/console/jmx and found that com.adobe.granite repository didn't appear.

I tried to delete the index folder in repository/ and start again but AEM instance still appear same error.

I tried these steps in below links, but I can not find out any information about latest good revision. So that I can not delete any row in journal.log file.

Fix Inconsistencies in the repository when SegmentNotFound Issue is reported in AEM 6.x

Please tell me is there any way to check and restore the instance again.

In case that if I can not restore it, could you please tell me there is any way how to copy the configuration files and content from the dead instance to the new one.

Thanks,

Any answer is highly appreciated.

View Entire Topic

chaud81156861

14-02-2019

Hi gauravb41175071

Thank you for your response.

I checked bundles that all of them are activated.

Then I tried to use a higher version of oak run package (oak-run v1.10 for AEM 6.4) to fix Inconsistence again, and found out the last good revision again. I removed some records in journal.log file and run compact command again. Finally the AEM instance can run back.

I have more than ten instances need to restore from this same error. Some instances were retored but they don't save any data or configuration. It look like the new AEM instance but some functions didn't work well. Is there any other way to restore the data and configuration settings of AEM instance?