Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

Bundle not startiing - Unresolved requirements

Avatar

Avatar
Validate 1
Level 1
s1101v
Level 1

Likes

0 likes

Total Posts

26 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Give Back
View profile

Avatar
Validate 1
Level 1
s1101v
Level 1

Likes

0 likes

Total Posts

26 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Give Back
View profile
s1101v
Level 1

01-03-2021

Hi All - I am getting the below error. Because of this issue, the bundle is not getting resolved. Can someone help with this?

 

s1101v_0-1614661988676.png

03.02.2021 00:06:45.616 *ERROR* [ anonymous-nosite-127.0.0.1-777db039-8efb-4aec-80a5-04ac005ebd09 ] org.apache.felix.http.jetty %bundles.pluginTitle: Cannot start (org.osgi.framework.BundleException: Unable to resolve product-mgt-landing.core [658](R 658.1): missing requirement [product-mgt-landing.core [658](R 658.1)] osgi.wiring.package; (osgi.wiring.package=com.adobe.cq.wcm.core.components.internal.models.v1) Unresolved requirements: [[product-mgt-landing.core [658](R 658.1)] osgi.wiring.package; (osgi.wiring.package=com.adobe.cq.wcm.core.components.internal.models.v1)])
org.osgi.framework.BundleException: Unable to resolve product-mgt-landing.core [658](R 658.1): missing requirement [product-mgt-landing.core [658](R 658.1)] osgi.wiring.package; (osgi.wiring.package=com.adobe.cq.wcm.core.components.internal.models.v1) Unresolved requirements: [[product-mgt-landing.core [658](R 658.1)] osgi.wiring.package; (osgi.wiring.package=com.adobe.cq.wcm.core.components.internal.models.v1)]
at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4368)
at org.apache.felix.framework.Felix.startBundle(Felix.java:2281)
at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:998)

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar
Validate 1
Level 6
KiranVedantam1992
Level 6

Likes

150 likes

Total Posts

155 posts

Correct Reply

44 solutions
Top badges earned
Validate 1
Establish
Give Back 3
Give Back
Boost 50
View profile

Avatar
Validate 1
Level 6
KiranVedantam1992
Level 6

Likes

150 likes

Total Posts

155 posts

Correct Reply

44 solutions
Top badges earned
Validate 1
Establish
Give Back 3
Give Back
Boost 50
View profile
KiranVedantam1992
Level 6

01-03-2021

Check the core.wcm.components.version and update it to the latest.

 

KiranVedantam1992_0-1614664829578.png

Hope this helps.

 

Thanks,

Kiran Vedantam.

Answers (2)

Answers (2)

Avatar

Avatar
Coach
Employee
Jörg_Hoh
Employee

Likes

1,081 likes

Total Posts

3,121 posts

Correct Reply

1,061 solutions
Top badges earned
Coach
Give back 600
Ignite 5
Ignite 3
Ignite 1
View profile

Avatar
Coach
Employee
Jörg_Hoh
Employee

Likes

1,081 likes

Total Posts

3,121 posts

Correct Reply

1,061 solutions
Top badges earned
Coach
Give back 600
Ignite 5
Ignite 3
Ignite 1
View profile
Jörg_Hoh
Employee

07-03-2021

That package is not exported by the bundle (just checked it with version 2.13.4). If you want to extend these core components, please check the documentaiton at https://experienceleague.adobe.com/docs/experience-manager-core-components/using/developing/customiz...

 

 

Avatar

Avatar
Coach
Employee
jbrar
Employee

Likes

377 likes

Total Posts

867 posts

Correct Reply

283 solutions
Top badges earned
Coach
Establish
Give Back 50
Give Back 5
Give Back 3
View profile

Avatar
Coach
Employee
jbrar
Employee

Likes

377 likes

Total Posts

867 posts

Correct Reply

283 solutions
Top badges earned
Coach
Establish
Give Back 50
Give Back 5
Give Back 3
View profile
jbrar
Employee

02-03-2021

Karan is right, This issue is related to core components version. Check [1] for more details:

 

[1] https://github.com/adobe/aem-core-wcm-components/releases