Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

Bundle installation and mapping issue in AEM 6.5

Avatar

Avatar
Validate 1
Level 1
vibhuranjan21
Level 1

Likes

2 likes

Total Posts

8 posts

Correct Reply

2 solutions
Top badges earned
Validate 1
Boost 1
Affirm 1
View profile

Avatar
Validate 1
Level 1
vibhuranjan21
Level 1

Likes

2 likes

Total Posts

8 posts

Correct Reply

2 solutions
Top badges earned
Validate 1
Boost 1
Affirm 1
View profile
vibhuranjan21
Level 1

08-02-2021

Hi Team,

 

After installing a new package, osgi bundle is not getting reflected under bundles. When we checked in osgi-installer (<ip>:<port>/system/console/osgi-installer), it is showing mapping with old version's bundle here.

We uninstalled and deleted all versions of the the project package from package manager. Now Project is not present in /apps as but when we checked the mapping in osgi-installer and it was still there. 

Installing package after increasing version is installing the bundle.

 

Manual installation of bundle through Felix console is working fine.

 

Any suggestion on this issue?

AEM 6.5 bundle
View Entire Topic

Avatar

Avatar
Validate 1
Level 7
KiranVedantam1992
Level 7

Likes

159 likes

Total Posts

159 posts

Correct Reply

47 solutions
Top badges earned
Validate 1
Establish
Give Back 3
Give Back
Boost 50
View profile

Avatar
Validate 1
Level 7
KiranVedantam1992
Level 7

Likes

159 likes

Total Posts

159 posts

Correct Reply

47 solutions
Top badges earned
Validate 1
Establish
Give Back 3
Give Back
Boost 50
View profile
KiranVedantam1992
Level 7

08-02-2021

Hi @vibhuranjan21,

 

Bundle installation can be done in the below ways:

  1. Via Maven build 
  2. Manually installing it in Felix console
  3. Adding it in the crx-quickstart/install

In general, installing it via maven build is a suggested approach. 

 

As per your query, it seems to be an issue with the version number of your project. Update it and try to install it again.

 

Hope this helps.

 

Thanks,

Kiran Vedantam