Bundle installation and mapping issue in AEM 6.5

Avatar

Avatar

vibhuranjan21

Avatar

vibhuranjan21

vibhuranjan21

08-02-2021

Hi Team,

 

After installing a new package, osgi bundle is not getting reflected under bundles. When we checked in osgi-installer (<ip>:<port>/system/console/osgi-installer), it is showing mapping with old version's bundle here.

We uninstalled and deleted all versions of the the project package from package manager. Now Project is not present in /apps as but when we checked the mapping in osgi-installer and it was still there. 

Installing package after increasing version is installing the bundle.

 

Manual installation of bundle through Felix console is working fine.

 

Any suggestion on this issue?

AEM 6.5 bundle

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar

vibhuranjan21

Avatar

vibhuranjan21

vibhuranjan21

10-02-2021

I found the solution for this problem:

 

Issue #1 : Bundle with new version was not getting installed:

The issue was related to an older version of "org.apache.sling.installer.factory.configuration". I installed the newer version of this bundle from <host>:<port>/system/console using the "Install/Update" option at the top right and restarted the instance.

Old version was 1.2.1 and now i have installed 1.3.4.

 

Issue #2: Old bundle was present and if we were deleting it, it was getting reflected after server restart

We checked the bundle in crx-quickstart/launchpad/felix and it was pointing to non existing jar file. So we have deleted this bundle after taking the backup of AEM.

After server restart, bundle was gone from the server.

Answers (2)

Answers (2)

Avatar

Avatar

Anudeep_Garnepudi

MVP

Avatar

Anudeep_Garnepudi

MVP

Anudeep_Garnepudi
MVP

09-02-2021

@vibhuranjan21 

Extract your package.zip like how you extract normal zip file and check your bundle version inside the package under jcr_root/apps/<project>-packages/application/install/xxxx.jar and see if it is latest or not.

Avatar

Avatar

KiranVedantam1992

Avatar

KiranVedantam1992

KiranVedantam1992

08-02-2021

Hi @vibhuranjan21,

 

Bundle installation can be done in the below ways:

  1. Via Maven build 
  2. Manually installing it in Felix console
  3. Adding it in the crx-quickstart/install

In general, installing it via maven build is a suggested approach. 

 

As per your query, it seems to be an issue with the version number of your project. Update it and try to install it again.

 

Hope this helps.

 

Thanks,

Kiran Vedantam