Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

Boost Value not working in full text search in AEM 6.1

Avatar

Avatar
Ignite 1
Level 2
cq_5_5
Level 2

Likes

2 likes

Total Posts

23 posts

Correct Reply

0 solutions
Top badges earned
Ignite 1
Validate 1
Give Back
Boost 1
View profile

Avatar
Ignite 1
Level 2
cq_5_5
Level 2

Likes

2 likes

Total Posts

23 posts

Correct Reply

0 solutions
Top badges earned
Ignite 1
Validate 1
Give Back
Boost 1
View profile
cq_5_5
Level 2

20-11-2015

We have a requirement of full text search where we have to show results based on relevancy. We have created a full text lucene index and assigned boost value to the properties. But we are not seeing any effect of boost value on the search results. Is there something else which is required to enable boost values in search? Our AEM version is 6.1 and oak version is Apache Jackrabbit Oak 1.2.2.

Attached is the index configuration and below is the query we are executing:
SELECT * FROM [nt:base] AS s WHERE (ISDESCENDANTNODE([/content/thf/en]) or ISDESCENDANTNODE([/content/dam/thf/en/docs])) and CONTAINS(s.*, 'Global Real Asset Fund') and ((s.[jcr:content/cq:tags] like '%thf:role/role1%') or (s.[jcr:content/metadata/cq:tags] like '%thf:role/role1%')) order by s.[jcr:score] desc

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar
Validate 1
Employee
Opkar_Gill
Employee

Likes

138 likes

Total Posts

952 posts

Correct Reply

280 solutions
Top badges earned
Validate 1
Give Back 50
Give Back 5
Give Back 3
Give Back 25
View profile

Avatar
Validate 1
Employee
Opkar_Gill
Employee

Likes

138 likes

Total Posts

952 posts

Correct Reply

280 solutions
Top badges earned
Validate 1
Give Back 50
Give Back 5
Give Back 3
Give Back 25
View profile
Opkar_Gill
Employee

20-11-2015

From the documentation, it appears Boost is only available from OAK version 1.2.5[1]

Regards,

Opkar

[1] https://jackrabbit.apache.org/oak/docs/query/lucene.html#boost

Answers (2)

Answers (2)

Avatar

Avatar
Validate 10
MVP
Amit_Kumar
MVP

Likes

329 likes

Total Posts

649 posts

Correct Reply

231 solutions
Top badges earned
Validate 10
Validate 1
Establish
Give Back 50
Give Back 5
View profile

Avatar
Validate 10
MVP
Amit_Kumar
MVP

Likes

329 likes

Total Posts

649 posts

Correct Reply

231 solutions
Top badges earned
Validate 10
Validate 1
Establish
Give Back 50
Give Back 5
View profile
Amit_Kumar
MVP

26-01-2016

Thanks everyone, I resolved this by installing 1.2.7 from 

 
    
Hot fix 7700 *

which was released in october 15.

Regards,

Amit

Avatar

Avatar
Validate 1
Level 2
Sunil_Chowdhary
Level 2

Like

1 like

Total Posts

27 posts

Correct Reply

2 solutions
Top badges earned
Validate 1
Boost 1
Applaud 5
Affirm 1
View profile

Avatar
Validate 1
Level 2
Sunil_Chowdhary
Level 2

Like

1 like

Total Posts

27 posts

Correct Reply

2 solutions
Top badges earned
Validate 1
Boost 1
Applaud 5
Affirm 1
View profile
Sunil_Chowdhary
Level 2

26-01-2016

Support boost:-

https://helpx.adobe.com/experience-manager/kb/aem61-available-hotfixes.html

To update Oak version to 1.2.7 or wait till Service Pack 1 gets released, which is scheduled for end of Q1 2016.