Expand my Community achievements bar.

Applications for the 2024-2025 Adobe Experience Manager Champion Program are open!

Automatic versioning of clientlibs not working in AEM 6.5.12

Avatar

Level 2

Hi,

 

Current AEM version is - 6.5.12

acs-aem-commons - 4.3.0

 

I configured the clientlib versioning as said in the acs commons site.

 

But the problem is, I have created the node for rewriter under config folder but it doesnt appear in the sling rewriter (http://localhost:4502/system/console/status-slingrewriter), so it indicates configuration was not applied successfully. I even restarted the server but it didnt worked.

 

Please anybody faced this issue.

 

Is it the acs-aem-commons version compatibility issue ?

 

4 Replies

Avatar

Level 2

@Ritesh_Mittal  Thanks , it is working for me , I created node

/apps/(myproject)/config/rewriter/versioned-clientlibs  and it is reflecting in the sling rewriter but its not working on JS and CSS concatenation version.

 

I tried making changes in JS and deployed code, it picked my changes , as I can see in console but when seeing in the Network tabs, the js is without any long string of number but for CSS I can see, a long string of numbers attached.

 

1. Chances are its picking for CSS and not for JS.

2. Either its not picking for both and its existing for CSS and not for JS.  (This is the case it seems, I checked on other env, its happening, without making any changes).

 

Any suggestions on this.

Avatar

Community Advisor

@Ss_dev you need to have 2 mandate things to be done, one acs commons osgi configuration and second rewrite node, this should be at exactly 4 level

 

/apps/(any custom folder)/config/rewriter

Avatar

Level 2

Thanks @Shashi_Mulugu  Its picking my config but the issue is testing. Even after making changes, its just not reflecting in js version but on the css version.

 

So I am not sure if the config had any impact on the clientlibs.