Asset expiration issue

Shaheena_ACC

21-09-2020

i uploaded a .jpg image in a folder in asset at 12:00. then i added the expire timing for that image in the properties at 14:00. The prior notification time was set to 3600 so i got notified at 13:00. The time based schedular was set to every 30 min, i got 1 notification after 30 min of expiration but after that, i didnt receive any further notification.

I have been tracking the log for the osgi config Adobe CQ DAM Expiry Notification. 

All i got was this:

----

GET /assets.html/content/dam/us/en/archive/images HTTP/1.1] com.day.cq.dam.core.impl.DamAdapterFactory Unable to adapt resource of sling:redirect to type com.day.cq.dam.api.Asset

 

GET /assets.html/content/dam/us/en/archive/images HTTP/1.1] com.day.cq.dam.core.impl.AssetImpl getSubAssets: couldn't get sub-assets, as the [subassets] folder doesn't exist for asset [/content/dam/us/en/archive/images/Capture.JPG]

 

GET /assets.html/content/dam/us/en/archive/images HTTP/1.1] com.day.cq.dam.core.impl.DamAdapterFactory Unable to adapt resource of granite/ui/components/coral/foundation/container to type com.day.cq.commons.LabeledResource

 

GET /assets.html/content/dam/us/en/archive/images HTTP/1.1] com.day.cq.dam.core.impl.DamAdapterFactory Unable to adapt resource of nt:file to type com.day.cq.dam.api.Asset

---

And if i set the prior notification timer to some minutes instead of some hours like 180 sec (3 min), then i dont get notified at all.

I have been following :

https://docs.adobe.com/content/help/en/experience-manager-65/assets/administer/drm.html

I am using AEM 6.5.6

Accepted Solutions (1)

Accepted Solutions (1)

Vijayalakshmi_S

MVP

23-09-2020

Hi @Shaheena_ACC,

Create a new log entry for the PID of Adobe CQ DAM Expiry Notification config  - com.day.cq.dam.core.impl.ExpiryNotificationJobImpl with level Debug in http://localhost:4502/system/console/slinglog and observe the behavior.

Not sure if it is a typo but the below statement from your original post seems ambiguous. Please clarify

"The time based schedular was set to every 30 min, i got 1 notification after 30 min of expiration but after that, i didnt receive any further notification." 

 

 

Answers (0)