My security team is informing vulnerabilities on Apache 2.2.X used in AEM 6.1 dispatcher.
Can I simply upgrade the Apache version from 2.2.X to 2.4.X?Could not find any documentation related to apache version for 6.1 dispatcher.
Or should I need to upgrade the dispatcher-module version along with Apache version? If yes what is the dispatcher module that I need to install on Apache 2.4.X?
Thanks in advance
Dispatcher version does not depend on AEM version. That said, you need to use the updated dispatcher module if you upgrade apache.
Example: Dispatcher version 4.2.3 works with apache 2.4.*
Check  for more details.
Adding to what Jaideep mentioned, to understand if the vulnerability you are referring to is fixed in Apache v2.4 you can consult the following document. In case the vulnerability is fixed then upgrading to v2.4 should address the vulnerability.
httpd 2.4 vulnerabilities - The Apache HTTP Server Project