Anchor tag and id issue

Avatar

Avatar
Validate 10
Level 3
tc82
Level 3

Likes

21 likes

Total Posts

64 posts

Correct reply

0 solutions
Top badges earned
Validate 10
Validate 1
Ignite 5
Ignite 3
Ignite 1
View profile

Avatar
Validate 10
Level 3
tc82
Level 3

Likes

21 likes

Total Posts

64 posts

Correct reply

0 solutions
Top badges earned
Validate 10
Validate 1
Ignite 5
Ignite 3
Ignite 1
View profile
tc82
Level 3

21-08-2018

Am seeing some issues with anchor tag in AEM rich text editor.

IN RTE if i use the the following:

<a href="test.com"> testing</a> -- Works well, href exists all the time.

second case:

<a href="test.com" id="test"> testing</a>

in source edit once you try to edit again, it becomes

<a  id="test"> testing</a> -- Doesn't work well, href is removed .

I have tried changing the  following file:

/apps/cq/xssprotection/config.xml

but nothing helped.

Has anyone seen this issue.

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar
Establish
Community Manager
kautuk_sahni
Community Manager

Likes

1,200 likes

Total Posts

6,394 posts

Correct reply

1,147 solutions
Top badges earned
Establish
Coach
Originator
Contributor 2
Contributor
View profile

Avatar
Establish
Community Manager
kautuk_sahni
Community Manager

Likes

1,200 likes

Total Posts

6,394 posts

Correct reply

1,147 solutions
Top badges earned
Establish
Coach
Originator
Contributor 2
Contributor
View profile
kautuk_sahni
Community Manager

22-08-2018

You can use the link icon for hyperlinking.

Here the concept of the anchor tag is placeholder hyperlink. To jump to a location within a page.

Here is the helpx article with package to do testing:- Configuring Experience Manager Rich Text Editor Plugins in a Touch UI Component Dialog

~kautuk

Answers (3)

Answers (3)

Avatar

Avatar
Validate 10
Level 3
tc82
Level 3

Likes

21 likes

Total Posts

64 posts

Correct reply

0 solutions
Top badges earned
Validate 10
Validate 1
Ignite 5
Ignite 3
Ignite 1
View profile

Avatar
Validate 10
Level 3
tc82
Level 3

Likes

21 likes

Total Posts

64 posts

Correct reply

0 solutions
Top badges earned
Validate 10
Validate 1
Ignite 5
Ignite 3
Ignite 1
View profile
tc82
Level 3

22-08-2018

kautuksahni​ We can try using that, but when users dump the whole html in the source edit, this issues is hard to resolve.

Avatar

Avatar
Validate 10
Level 3
tc82
Level 3

Likes

21 likes

Total Posts

64 posts

Correct reply

0 solutions
Top badges earned
Validate 10
Validate 1
Ignite 5
Ignite 3
Ignite 1
View profile

Avatar
Validate 10
Level 3
tc82
Level 3

Likes

21 likes

Total Posts

64 posts

Correct reply

0 solutions
Top badges earned
Validate 10
Validate 1
Ignite 5
Ignite 3
Ignite 1
View profile
tc82
Level 3

21-08-2018

Sorry forgot to mention. We are using AEM 6.3

Avatar

Avatar
Validate 25
Level 10
smacdonald2008
Level 10

Likes

1,409 likes

Total Posts

12,671 posts

Correct reply

2,278 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Give back 900
Give back 600
View profile

Avatar
Validate 25
Level 10
smacdonald2008
Level 10

Likes

1,409 likes

Total Posts

12,671 posts

Correct reply

2,278 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Give back 900
Give back 600
View profile
smacdonald2008
Level 10

21-08-2018

What version of AEM Are you using?