After upgrade from AEM 6.1 to 6.4, i18n internationalization not working

deepak3344

27-12-2018

Hi all,

We upgraded from AEM 6.1 to 6.4, here one finding we have is i18n keys are not working with translated values not appearing on the page, the key is printed on the page.

Since it used to work in 6.1, is there any change which is preventing it to work in 6.4. the suggestion will be helpful.

Regards

Accepted Solutions (1)

Accepted Solutions (1)

deepak3344

28-12-2018

Hi Vijay,

Yes, I am facing the same issue.

One of the root cause I find is somehow /libs/cq/i18n/dict.en_US.json and respective locales dictionary not rendering the keys and translations which it used to render in 6.1.

Regards

Answers (5)

Answers (5)

vijays80591732

28-12-2018

Hi Deepak,

What are all the bundles you have restarted? And from the component how you are calling the i18n. Are you having separate i18n folder in /apps/yourproject  and inside i18n folder are you having any .json file which would having i18n keys and values? Also what is the i18n dependency version you are using? Please share your inputs.

Thanks,

Vijay

vijays80591732

28-12-2018

Hi Deepak,

I have verified this abode helpx article i18n translations are no longer working . But this will helps only if you are working in some higher environments and if you are not logged in as Admin. Please have a try. In my case it is not workout since I'm trying in my local and logged in as Admin.

kautuksahniArun Patidar

Thanks,

Vijay

vijays80591732

28-12-2018

Hi Deepak,

Is that issue fixed? I'm facing the same issue. But I couldn't find out the root cause. If you know the fix please let here know.

Arun Patidarkautuksahnismacdonald2008​ - can anyone help me on this?

Thanks,

Vijay