Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

AEM Workflow Assign Task is not submitting after adding attachment to Adaptive Form

Avatar

Level 2

Hello eveyrone,

 

Right now, I'm having an issue with my workflow, when a user opens up a assign task and adds an attachment using the File Attachment field from an Adaptive Form, when the user tries to submit it nothing is happening the assign task still remains active. Basically, how the attachment feature works is that in the pre-populated and submitted information configuration I added the following configuration:

 

SebasRios34_0-1645202020949.pngSebasRios34_1-1645202029813.png

 

So when the user adds the attachment in the following field, is saved on the payload directory:

 

SebasRios34_2-1645202090172.png

As you can see in the picture below, the attachment is being added successfully in the payload directory, but that's it. The assign task still remains active in the inbox menu like if the user hasn't open it yet.

 

SebasRios34_3-1645202219364.png

 

Below the assign task step in the workflow, we have a custom zip payload directory, whichs zips the attachment folder so that it can be send via an email step. In order, to create the zip payload step we used the following adobe documentation

 

SebasRios34_4-1645202297168.png

 

Does somebody know what could be stopping the assign task from being submitted?

0 Replies