AEM unable to login

Avatar

Avatar

Anwar_Sadat

Avatar

Anwar_Sadat

Anwar_Sadat

15-10-2015

Hi Experts,

We are running AEM 6.0 with SP2. After a recent restart of one of our publish instance, we are no longer able to login with admin credentials.

We keep getting the following error in the logs:

 

16.10.2015 13:49:40.262 *WARN* [qtp2074601335-30] org.eclipse.jetty.servlet.ServletHandler /libs/granite/core/content/login.html
java.lang.IllegalArgumentException: Invalid token ''
        at org.apache.jackrabbit.api.security.authentication.token.TokenCredentials.<init>(TokenCredentials.java:42)
        at com.day.crx.security.token.impl.TokenAuthenticationHandler.createCredentials(TokenAuthenticationHandler.java:578)
        at com.day.crx.security.token.impl.TokenAuthenticationHandler.extractCredentials(TokenAuthenticationHandler.java:352)
        at org.apache.sling.auth.core.impl.AuthenticationHandlerHolder.doExtractCredentials(AuthenticationHandlerHolder.java:75)
        at org.apache.sling.auth.core.impl.AbstractAuthenticationHandlerHolder.extractCredentials(AbstractAuthenticationHandlerHolder.java:60)
        at org.apache.sling.auth.core.impl.SlingAuthenticator.getAuthenticationInfo(SlingAuthenticator.java:697)
        at org.apache.sling.auth.core.impl.SlingAuthenticator.doHandleSecurity(SlingAuthenticator.java:452)
        at org.apache.sling.auth.core.impl.SlingAuthenticator.handleSecurity(SlingAuthenticator.java:438)
        at org.apache.sling.engine.impl.SlingHttpContext.handleSecurity(SlingHttpContext.java:121)

 

Any help in this regard is much appreciated !!!

 

Thanks,

Anwar

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar

danielp80910212

Avatar

danielp80910212

danielp80910212

04-12-2017

Hi.

I know it is old, but someone could have the same problem as I did today.

We have this project in AEM 6.0 and I had the very same issue.

The problem is when you have a working instance and try to run it using the command line:

java -server -XX:MaxPermSize=256m -Xmx4024M -jar cq56-author-p4502.jar -r author, nosamplecontent

Using the /bin/ ./start should let it start normally.

It worked for me.

Answers (11)

Answers (11)

Avatar

Avatar

Naveen_AEM_dev

Avatar

Naveen_AEM_dev

Naveen_AEM_dev

08-03-2016

I faced this issue sometime back and resolved it by deleting the cookies which removes the login-token cookie value.

Once this cookie is removed, I tried to login again which set the proper cookie / token value and I was able to login fine!

Avatar

Avatar

venkatr80216678

Avatar

venkatr80216678

venkatr80216678

06-12-2017

This is help full. Thank you

Avatar

Avatar

smacdonald2008

Total Posts

12.7K

Likes

1.4K

Correct Reply

2.3K

Avatar

smacdonald2008

Total Posts

12.7K

Likes

1.4K

Correct Reply

2.3K
smacdonald2008

04-12-2017

Thank you for posting your fix!

Avatar

Avatar

kamalakar_rao

Avatar

kamalakar_rao

kamalakar_rao

07-03-2016

and the OS version is RHEL

Avatar

Avatar

kamalakar_rao

Avatar

kamalakar_rao

kamalakar_rao

07-03-2016

Hello Samir,

We are on

java version "1.8.0_25"
Java(TM) SE Runtime Environment (build 1.8.0_25-b17)
Java HotSpot(TM) 64-Bit Server VM (build 25.25-b02, mixed mode)

AEM 6.0 SP1

 

Thanks

Kamal

Avatar

Avatar

__96

Avatar

__96

__96

07-03-2016

Can you let us know your OS version and Jdk version ? Such issues have been observed with Java version and windows 8. Please check this link

https://docs.adobe.com/docs/en/aem/6-0/deploy/technical-requirements.html#Supported Platforms

Regards,

Samir

Avatar

Avatar

kamalakar_rao

Avatar

kamalakar_rao

kamalakar_rao

07-03-2016

Hi Anwar, 

I am also facing the same issue. How did you resolved this issue?

Any help will be appreciated.

Regards

Kamal

Avatar

Avatar

Opkar_Gill

Employee

Avatar

Opkar_Gill

Employee

Opkar_Gill
Employee

16-10-2015

Hi Anwar,

are there any exceptions in your error.log during startup? Have all the bundles started in your instance?

Regards,

Opkar

Avatar

Avatar

smacdonald2008

Total Posts

12.7K

Likes

1.4K

Correct Reply

2.3K

Avatar

smacdonald2008

Total Posts

12.7K

Likes

1.4K

Correct Reply

2.3K
smacdonald2008

16-10-2015

Was there any custom implementation or other changes done to your AEM instance that may account for the changed behaviour in the token?      

Avatar

Avatar

Anwar_Sadat

Avatar

Anwar_Sadat

Anwar_Sadat

16-10-2015

Hi- Figured out that the authentication is successful. But the "login-token" cookie return by AEM is not valid.

It is supposed to be like: login-token=4177bc3c-8d72-40e2-be47-bd6f93c1b5ae%3ad7bd26b3-cd48-4430-b7d7-d60fdecb2361_660c460ab31f8e8f%3acrx.default

But it looks like this: login-token=117182c7-02d4-4c88-97b3-0714fa1ff3b2%3a<MISSING TOKEN>%3acrx.default

Any idea why this could have happened and any remedies?

Avatar

Avatar

PuzanovsP

MVP

Avatar

PuzanovsP

MVP

PuzanovsP
MVP

16-10-2015

        Right, well after recent restart something must have happened to your system. As this exception is not the most explanatory one check earlier in the logs for more meaningful hints to what has happened and why authentication does not want to work. Thanks, Peter