AEM Smart crop - Issues

Avatar

Avatar
Validate 1
Level 1
tulasi21
Level 1

Likes

0 likes

Total Posts

3 posts

Correct reply

0 solutions
Top badges earned
Validate 1
View profile

Avatar
Validate 1
Level 1
tulasi21
Level 1

Likes

0 likes

Total Posts

3 posts

Correct reply

0 solutions
Top badges earned
Validate 1
View profile
tulasi21
Level 1

19-06-2021

Hello All,

Am facing few issues with the AEM smart crop :

1. We have dynamic media settings on, Still am not able to publish the images.

 

2. Am not seeing any image profiles, though i have created many till now.

 
Updating Media

3. In the dynamic media component when am selecting the smart crop and returning back the smart crop is not selected anymore.

 

tulasi21_1-1624041230596.png

 

 

Sorry so many issues, I feel this smart crop is so painful

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar
Establish
Employee
VikramGaur
Employee

Likes

42 likes

Total Posts

68 posts

Correct reply

24 solutions
Top badges earned
Establish
Give Back 5
Give Back 3
Give Back
Boost 5
View profile

Avatar
Establish
Employee
VikramGaur
Employee

Likes

42 likes

Total Posts

68 posts

Correct reply

24 solutions
Top badges earned
Establish
Give Back 5
Give Back 3
Give Back
Boost 5
View profile
VikramGaur
Employee

21-06-2021

Hi,

Welcome to Adobe AEM Community

What is the exact version of your AEM instance?

What run mode is used to Dynamic Media?

Have you applied any Smart Crop image profile to a folder, where assets are placed on uploaded?

Are you able to reproduce that component issue with different pages?

Thanks,

Vikram Gaur

 

tulasi21

Hello Vikram, 

Please see the answers below:

1. AEM version :  6.5.8.0 

2. Have you applied any Smart Crop image profile to a folder, where assets are placed on uploaded? _  Yes, I did.

3. Are you able to reproduce that component issue with different pages?- Yes tried this outof box component on experience fragments and content pages too. Same issue, the smart crop option is not getting saved. 

By default first option "Image Preset" is getting stored.

4. What run mode is used to Dynamic Media? - Its on .

 

Also I noticed adding a new "

Responsive Image Crop

" in the image profiles is not getting honored. can we add our custom dimensions?

 

Thanks for your help.

 

Thanks,

Tulasi.

VikramGaur
Hi Tulasi,
VikramGaur
Hi Tulasi, Thank you for your response
VikramGaur

Hi Tulasi,

Thank you for your response.

I am assuming, you have "dynamicmedia_scene7" run mode on your AEM 6.5.8 Author instance.

Have you created a Dynamic Media configuration (Tools -> Cloud Services -> Dynamic Media Configuration)

If yes, when you click on Tools -> Assets -> Viewer Presets, do you see a list of Viewer Presets?


To answer you question, you may click on Tools -> Assets -> Image Profiles and edit you "Smart Crop Profile" to add another Responsive Image crop with custom dimensions.

Answers (0)