Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

AEM server is running locally but localhost refuses to connect

Avatar

Avatar
Validate 1
Level 1
gavf
Level 1

Likes

0 likes

Total Posts

1 post

Correct Reply

0 solutions
Top badges earned
Validate 1
View profile

Avatar
Validate 1
Level 1
gavf
Level 1

Likes

0 likes

Total Posts

1 post

Correct Reply

0 solutions
Top badges earned
Validate 1
View profile
gavf
Level 1

03-06-2021

I am trying to run an AEM site locally on a mac I run the server using the command

java -Xmx2048m -jar AEM_6.4_Quickstart.jar

I am getting this response back:

Loading quickstart properties: default
Loading quickstart properties: instance
Low-memory action set to fork
Using 64bit VM settings, min.heap=1024MB, min permgen=256MB, default fork arguments=[-Xmx1024m, -XX:MaxPermSize=256m]
The JVM reports a heap size of 2048 MB, meets our expectation of 1024 MB +/- 20
Setting properties from filename '/Users/jimmymona/Development/OnBeat/TFS/AEM_6.4_Quickstart.jar'
Verbose option not active, closing stdin and redirecting stdout and stderr
Redirecting stdout to /Users/jimmymona/Development/OnBeat/TFS/crx-quickstart/logs/stdout.log
Redirecting stderr to /Users/jimmymona/Development/OnBeat/TFS/crx-quickstart/logs/stderr.log
Press CTRL-C to shutdown the Quickstart server...


/Users/jimmymona/Development/OnBeat/TFS/crx-quickstart/logs/stdout.log is showing this:

Loading quickstart properties: default
Loading quickstart properties: instance
Quickstart startup at Wed Jun 02 11:33:24 EDT 2021
UpgradeUtil.handleInstallAndUpgrade has mode RESTART
02.06.2021 11:33:24.188 *INFO * [main] Setting sling.home=/Users/jimmymona/Development/OnBeat/TFS/crx-quickstart (command line)
02.06.2021 11:33:24.189 *INFO * [main] Starting Apache Sling in /Users/jimmymona/Development/OnBeat/TFS/crx-quickstart
02.06.2021 11:33:24.191 *INFO * [main] Sling Extension Lib Home : /Users/jimmymona/Development/OnBeat/TFS/crx-quickstart/launchpad/ext
02.06.2021 11:33:24.195 *INFO * [main] Checking launcher JAR in folder /Users/jimmymona/Development/OnBeat/TFS/crx-quickstart/launchpad
02.06.2021 11:33:24.205 *INFO * [main] Existing launcher is up to date, using it: 5.6.10.2_6_26 (org.apache.sling.launchpad.base.jar)
02.06.2021 11:33:24.206 *INFO * [main] Loading launcher class org.apache.sling.launchpad.base.app.MainDelegate from org.apache.sling.launchpad.base.jar
02.06.2021 11:33:24.206 *INFO * [main] External Libs Home (ext) is null or does not exists.
02.06.2021 11:33:24.213 *INFO * [main] Setting sling.properties=conf/sling.properties
02.06.2021 11:33:24.213 *INFO * [main] Setting sling.home=/Users/jimmymona/Development/OnBeat/TFS/crx-quickstart
02.06.2021 11:33:24.213 *INFO * [main] Setting sling.launchpad=/Users/jimmymona/Development/OnBeat/TFS/crx-quickstart/launchpad
02.06.2021 11:33:24.213 *INFO * [main] Setting org.osgi.service.http.port=4502
02.06.2021 11:33:24.213 *INFO * [main] Starting launcher ...
02.06.2021 11:33:24.218 *INFO * [main] HTTP server port: 4502
02.06.2021 11:33:24.353 *INFO * [main] Startup completed


/Users/jimmymona/Development/OnBeat/TFS/crx-quickstart/logs/stderr.log is showing:

Low-memory action set to fork
Using 64bit VM settings, min.heap=1024MB, min permgen=256MB, default fork arguments=[-Xmx1024m, -XX:MaxPermSize=256m]
The JVM reports a heap size of 2048 MB, meets our expectation of 1024 MB +/- 20
Setting properties from filename '/Users/jimmymona/Development/OnBeat/TFS/AEM_6.4_Quickstart.jar'
Verbose option not active, closing stdin and redirecting stdout and stderr
Redirecting stdout to /Users/jimmymona/Development/OnBeat/TFS/crx-quickstart/logs/stdout.log
Redirecting stderr to /Users/jimmymona/Development/OnBeat/TFS/crx-quickstart/logs/stderr.log
ResourceProvider paths=[/gui, /gui/default]

So it looks like everything is running properly, but localhost:4502 is showing "This site can’t be reached" with "ERR_CONNECTION_REFUSED". I am not running any Proxies and my Firewall is off, not sure what else to check. Any ideas?

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar
Boost 100
Level 7
rush_pawan
Level 7

Likes

120 likes

Total Posts

192 posts

Correct Reply

77 solutions
Top badges earned
Boost 100
Validate 1
Ignite 1
Give Back 5
Give Back 3
View profile

Avatar
Boost 100
Level 7
rush_pawan
Level 7

Likes

120 likes

Total Posts

192 posts

Correct Reply

77 solutions
Top badges earned
Boost 100
Validate 1
Ignite 1
Give Back 5
Give Back 3
View profile
rush_pawan
Level 7

03-06-2021

can you check if it can be accessed via 127.0.0.1:4502 or with your IP?

(if above doesn't work then)

share the log from error.log when you hit the browser using http://localhost:4502

Answers (1)

Answers (1)

Avatar

Avatar
Establish
Level 3
kchaurasiya
Level 3

Likes

17 likes

Total Posts

21 posts

Correct Reply

4 solutions
Top badges earned
Establish
View profile

Avatar
Establish
Level 3
kchaurasiya
Level 3

Likes

17 likes

Total Posts

21 posts

Correct Reply

4 solutions
Top badges earned
Establish
View profile
kchaurasiya
Level 3

03-06-2021

Try to open the system console (http://localhost:4502/system/console/bundles ) first and see whether all bundles are in active mode or not. If you are able to open the system/console and all the bundles are in active then there is no issue with the server. Some issue might be from the component/html or fronted.