Highlighted

AEM Screens Player (Windows) - Wrong URL being used

Avatar

Avatar

khoah64199733

Avatar

khoah64199733

khoah64199733

20-08-2018

Hi all,

I am using a custom made Single Page App component inside AEM Screens Editor. Everything seems to work fine when previewing on a Chrome browser. However, when I go to test it out on Screens Player for Windows, all of my media assets do not load. So, I did some digging around some log files found under \AppData\Roaming\com.adobe.aem.screens.player\File System\000\p\00.

--- BEGINNING OF LOG FILE ----

--- END OF LOG FILE ----

But, I want to refer specifically to line 29 of the file attached.

I am fairly confident that it should be loading the content from localhost:4502, but not sure how I can fix this. Do you have any suggestions? Any help would be appreciated and thank you for your time!

Replies

Highlighted

Avatar

Avatar

Bharath_valse

Avatar

Bharath_valse

Bharath_valse

20-08-2018

Can you try updating the content offline from the channel? Whats your player version?

Highlighted

Avatar

Avatar

Bharath_valse

Avatar

Bharath_valse

Bharath_valse

20-08-2018

Also port 24502 is the player content port. which is an implicit port

Highlighted

Avatar

Avatar

khoah64199733

Avatar

khoah64199733

khoah64199733

20-08-2018

Hi Bharath,

Thanks for your response! So I've tried updating the content offline and it does not work still. As for player version, it is 2.3.2.

What is strange actually is that one of the Channels is working.

I have 3 channels - each using the same footer and background image asset. However, it seems only Exhibit 1 is loading the background and footer image correctly while the rest does not even load the CSS or image assets.

Highlighted

Avatar

Avatar

khoah64199733

Avatar

khoah64199733

khoah64199733

21-08-2018

A little update on things: I was able to test on a Mac and everything seems to be working fine with that version of the Screens Player. So, that narrows the issue to the Windows Screen Player itself. I'd appreciate any insight and thanks for your time!

Highlighted

Avatar

Avatar

Bharath_valse

Avatar

Bharath_valse

Bharath_valse

21-08-2018

Can you try downloading the latest windows player from [0] for AEM 6.3 and [1] for AEM 6.4, make sure its the right AEM version including SPs

[0] AEM Screens Player - Previous Versions

[1] AEM Screens Player - Downloads