AEM not loaded after compaction

Manh_Nguyen

15-05-2019

Hi,

I have an issue after running compaction for my system, the compaction log said compaction was successful. But when starting up, all of the requests are returning 503 including crx/de. I tried accessing OSGi bundles and all are started and active. Also checked error.log but nothing found. I also had to key in the default admin password to access to OSGi bundles although I've changed the admin password (password was working before compaction).

I noticed in stdout.log, it's missing the loading of ESAPI.properties and validation.properties when startup. Other instances have different startup log in stdout.log. Below logs are for the not working and working instances.

1. stdout.log in not working instance:

Loading quickstart properties: default

Loading quickstart properties: instance

Quickstart startup at Mon May 13 23:59:31 SGT 2019

UpgradeUtil.handleInstallAndUpgrade has mode RESTART

13.05.2019 23:59:31.712 *INFO * [main] Setting sling.home=/mnt/crx/publish/crx-quickstart (command line)

13.05.2019 23:59:31.713 *INFO * [main] Starting Apache Sling in /mnt/crx/publish/crx-quickstart

13.05.2019 23:59:31.725 *INFO * [main] Sling  Extension Lib Home : /mnt/crx/publish/crx-quickstart/launchpad/ext

13.05.2019 23:59:31.815 *INFO * [main] Checking launcher JAR in folder /mnt/crx/publish/crx-quickstart/launchpad

13.05.2019 23:59:32.008 *INFO * [main] Existing launcher is up to date, using it: 5.4.0.2_6_10-B004 (org.apache.sling.launchpad.base.jar)

13.05.2019 23:59:32.009 *INFO * [main] Loading launcher class org.apache.sling.launchpad.base.app.MainDelegate from org.apache.sling.launchpad.base.jar

13.05.2019 23:59:32.010 *INFO * [main] External Libs Home (ext) is null or does not exists.

13.05.2019 23:59:32.055 *INFO * [main] Setting sling.properties=conf/sling.properties

13.05.2019 23:59:32.055 *INFO * [main] Setting sling.home=/mnt/crx/publish/crx-quickstart

13.05.2019 23:59:32.055 *INFO * [main] Setting sling.launchpad=/mnt/crx/publish/crx-quickstart/launchpad

13.05.2019 23:59:32.055 *INFO * [main] Setting org.osgi.service.http.port=4503

13.05.2019 23:59:32.055 *INFO * [main] Starting launcher ...

13.05.2019 23:59:32.062 *INFO * [main] HTTP server port: 4503

14.05.2019 00:00:29.425 *INFO* [FelixStartLevel] org.apache.sling.commons.log.logback.internal.Activator LogbackManager initialized at bundle startup

14.05.2019 00:00:29.761 *INFO* [FelixStartLevel] log4j.over.slf4j BundleEvent RESOLVED

14.05.2019 00:00:29.762 *INFO* [FelixStartLevel] log4j.over.slf4j BundleEvent STARTING

14.05.2019 00:00:29.764 *INFO* [FelixStartLevel] log4j.over.slf4j BundleEvent STARTED

14.05.2019 00:00:29.794 *INFO* [FelixStartLevel] org.apache.sling.javax.activation BundleEvent RESOLVED

14.05.2019 00:00:29.794 *INFO* [FelixStartLevel] org.apache.sling.javax.activation BundleEvent STARTING

14.05.2019 00:00:29.821 *INFO* [FelixStartLevel] org.apache.sling.settings BundleEvent RESOLVED

14.05.2019 00:00:29.822 *INFO* [FelixStartLevel] org.apache.sling.installer.provider.file BundleEvent RESOLVED

14.05.2019 00:00:29.822 *INFO* [FelixStartLevel] org.apache.sling.installer.core BundleEvent RESOLVED

14.05.2019 00:00:29.822 *INFO* [FelixStartLevel] org.apache.sling.installer.provider.file BundleEvent STARTING

14.05.2019 00:00:29.905 *INFO* [FelixStartLevel] org.apache.aries.util BundleEvent RESOLVED

14.05.2019 00:00:29.905 *INFO* [FelixStartLevel] org.apache.aries.util BundleEvent STARTING

14.05.2019 00:00:29.905 *INFO* [FelixStartLevel] org.apache.aries.util BundleEvent STARTED

14.05.2019 00:01:27.432 *INFO * [main] Startup completed

2. stdout.log in working instances:

Loading quickstart properties: default

Loading quickstart properties: instance

Quickstart startup at Mon May 13 23:59:31 SGT 2019

UpgradeUtil.handleInstallAndUpgrade has mode RESTART

13.05.2019 23:59:31.712 *INFO * [main] Setting sling.home=/mnt/crx/publish/crx-quickstart (command line)

13.05.2019 23:59:31.713 *INFO * [main] Starting Apache Sling in /mnt/crx/publish/crx-quickstart

13.05.2019 23:59:31.725 *INFO * [main] Sling  Extension Lib Home : /mnt/crx/publish/crx-quickstart/launchpad/ext

13.05.2019 23:59:31.815 *INFO * [main] Checking launcher JAR in folder /mnt/crx/publish/crx-quickstart/launchpad

13.05.2019 23:59:32.008 *INFO * [main] Existing launcher is up to date, using it: 5.4.0.2_6_10-B004 (org.apache.sling.launchpad.base.jar)

13.05.2019 23:59:32.009 *INFO * [main] Loading launcher class org.apache.sling.launchpad.base.app.MainDelegate from org.apache.sling.launchpad.base.jar

13.05.2019 23:59:32.010 *INFO * [main] External Libs Home (ext) is null or does not exists.

13.05.2019 23:59:32.055 *INFO * [main] Setting sling.properties=conf/sling.properties

13.05.2019 23:59:32.055 *INFO * [main] Setting sling.home=/mnt/crx/publish/crx-quickstart

13.05.2019 23:59:32.055 *INFO * [main] Setting sling.launchpad=/mnt/crx/publish/crx-quickstart/launchpad

13.05.2019 23:59:32.055 *INFO * [main] Setting org.osgi.service.http.port=4503

13.05.2019 23:59:32.055 *INFO * [main] Starting launcher ...

13.05.2019 23:59:32.062 *INFO * [main] HTTP server port: 4503

14.05.2019 00:00:29.425 *INFO* [FelixStartLevel] org.apache.sling.commons.log.logback.internal.Activator LogbackManager initialized at bundle startup

14.05.2019 00:00:29.761 *INFO* [FelixStartLevel] log4j.over.slf4j BundleEvent RESOLVED

14.05.2019 00:00:29.762 *INFO* [FelixStartLevel] log4j.over.slf4j BundleEvent STARTING

14.05.2019 00:00:29.764 *INFO* [FelixStartLevel] log4j.over.slf4j BundleEvent STARTED

14.05.2019 00:00:29.794 *INFO* [FelixStartLevel] org.apache.sling.javax.activation BundleEvent RESOLVED

14.05.2019 00:00:29.794 *INFO* [FelixStartLevel] org.apache.sling.javax.activation BundleEvent STARTING

14.05.2019 00:00:29.821 *INFO* [FelixStartLevel] org.apache.sling.settings BundleEvent RESOLVED

14.05.2019 00:00:29.822 *INFO* [FelixStartLevel] org.apache.sling.installer.provider.file BundleEvent RESOLVED

14.05.2019 00:00:29.822 *INFO* [FelixStartLevel] org.apache.sling.installer.core BundleEvent RESOLVED

14.05.2019 00:00:29.822 *INFO* [FelixStartLevel] org.apache.sling.installer.provider.file BundleEvent STARTING

14.05.2019 00:00:29.905 *INFO* [FelixStartLevel] org.apache.aries.util BundleEvent RESOLVED

14.05.2019 00:00:29.905 *INFO* [FelixStartLevel] org.apache.aries.util BundleEvent STARTING

14.05.2019 00:00:29.905 *INFO* [FelixStartLevel] org.apache.aries.util BundleEvent STARTED

Attempting to load ESAPI.properties via file I/O.

Attempting to load ESAPI.properties as resource file via file I/O.

Not found in 'org.owasp.esapi.resources' directory or file not readable: /mnt/crx/publish/ESAPI.properties

Not found in SystemResource Directory/resourceDirectory: .esapi/ESAPI.properties

Not found in 'user.home' (/home/crx) directory: /home/crx/esapi/ESAPI.properties

Loading ESAPI.properties via file I/O failed. Exception was: java.io.FileNotFoundException

Attempting to load ESAPI.properties via the classpath.

SUCCESSFULLY LOADED ESAPI.properties via the CLASSPATH from '/ (root)' using class loader for DefaultSecurityConfiguration class!

Attempting to load validation.properties via file I/O.

Attempting to load validation.properties as resource file via file I/O.

Not found in 'org.owasp.esapi.resources' directory or file not readable: /mnt/crx/publish/validation.properties

Not found in SystemResource Directory/resourceDirectory: .esapi/validation.properties

Not found in 'user.home' (/home/crx) directory: /home/crx/esapi/validation.properties

Loading validation.properties via file I/O failed.

Attempting to load validation.properties via the classpath.

SUCCESSFULLY LOADED validation.properties via the CLASSPATH from '/ (root)' using class loader for DefaultSecurityConfiguration class!

14.05.2019 00:07:27.432 *INFO * [main] Startup completed

Is there something wrong with my instance? Any advise would be appreciated.

My instance is AEM 6.2-SP1 CFP14.

Thanks.

Accepted Solutions (1)

Accepted Solutions (1)

berliant

Employee

16-05-2019

ESAPI.properties is not an issue. Check if data*.tar file has RW permissions for an account that you are using to start AEM.

Are you able to access /system/console?

Also, tail stderr.log file. If there is an error on startup it will be thrown into stderr.log.

Answers (2)

Answers (2)

Manh_Nguyen

29-05-2019

Hi,

Thanks for your advise! Looks like it's because the user that run AEM does not have the permission RW to the *.tar file. I changed the owner and AEM can be started.

Thanks a lot.

Manh_Nguyen

16-05-2019

Hi,

Thanks for your reply.

Yes I'm able to access /system/console. And all bundles are active. But I had to login using default admin account although I had changed admin password.