AEM integration with Hybris

Avatar

Avatar

samery56615784

Avatar

samery56615784

samery56615784

15-08-2016

Hi Experts,

Did any one integrated the Hybris with AEM6.1? Can anyone share the step by step guide or any document that help us.

Thanks

~S

Replies

Avatar

Avatar

smacdonald2008

Total Posts

12.7K

Likes

1.4K

Correct Reply

2.3K

Avatar

smacdonald2008

Total Posts

12.7K

Likes

1.4K

Correct Reply

2.3K
smacdonald2008

15-08-2016

Here is the Official AEM Docs on this subject: 

https://docs.adobe.com/docs/en/aem/6-0/develop/ecommerce/hybris.html

Hope this helps... 

Avatar

Avatar

samery56615784

Avatar

samery56615784

samery56615784

15-08-2016

Hi Experts,

We are creating custom Adobe CQ commerce providers as per below example in URL.

https://helpx.adobe.com/experience-manager/using/creating-custom-cq-commerce-providers.html

It is throwing the error for com.adobe.cq.commerce.api versions mismatch.

Which version of com.adobe.cq.commerce.api fit for AEM 6.1? We already tried with 5.6.8 and 5.6.13 and also the uber-obsfucator as well.

Anyone have any example URL for AEM 6.1?

Thanks

~S

Avatar

Avatar

kautuk_sahni

Community Manager

Total Posts

5.8K

Likes

1.0K

Correct Reply

1.1K

Avatar

kautuk_sahni

Community Manager

Total Posts

5.8K

Likes

1.0K

Correct Reply

1.1K
kautuk_sahni
Community Manager

16-08-2016

Hi 

The article you are referring here is tested on AEM 5.6.

Here in the article, the POM dependency used for "com.adobe.cq.commerce.api" is:-

//    <dependency>
            <groupId>com.adobe.cq.commerce</groupId>
            <artifactId>cq-commerce-core</artifactId>
            <version>5.6.8</version>
            <scope>provided</scope>
        </dependency>

 

I would say, go to :- http://localhost:4502/system/console/depfinder [Dependency finder] and add "com.adobe.cq.commerce.api" to Package/Classes and click Find.

This will show you the dependency...

As for 6.2, it is coming out to be:-

    <dependency>
        <groupId>com.adobe.cq.commerce</groupId>
        <artifactId>cq-commerce-core</artifactId>
        <version>5.14.102</version>
        <scope>provided</scope>
    </dependency>

 

For 6.1, it is :- 

<dependency>
    <groupId>com.adobe.cq.commerce</groupId>
    <artifactId>cq-commerce-core</artifactId>
    <version>5.13.12</version>
    <scope>provided</scope>
</dependency>

 

I hope this would help you.

Thanks and Regards

Kautuk Sahni

Avatar

Avatar

kautuk_sahni

Community Manager

Total Posts

5.8K

Likes

1.0K

Correct Reply

1.1K

Avatar

kautuk_sahni

Community Manager

Total Posts

5.8K

Likes

1.0K

Correct Reply

1.1K
kautuk_sahni
Community Manager

16-08-2016

Apart from the above mentioned, there is a official documentation :- https://docs.adobe.com/docs/en/aem/6-1/develop/ecommerce/hybris.html

~kautuk

Avatar

Avatar

samery56615784

Avatar

samery56615784

samery56615784

16-08-2016

Hi Kautuk,

We are using below dependency in AEm 6.1:

<dependency>
    <groupId>com.adobe.cq.commerce</groupId>
    <artifactId>cq-commerce-core</artifactId>
    <version>5.13.12</version>
    <scope>provided</scope>
</dependency>

it is compiling correctly in local environment but getting the below error when publishing on the server:

Failed installing bundle : Unable to install/update bundle from dir \core\target\classes : Unresolved constraint[716]: Unable to resolve 716.0: missing requirement [716.0] osgi.wiring.package; (&(osgi.wiring.package=com.adobe.cq.commerce.api)(version>=1.2.0)(!(version>=2.0.0)))

and on bundle console below error:

com.adobe.cq.commerce.api,version=[1.2,2) -- Cannot be resolved
com.adobe.cq.commerce.api.promotion,version=[1.2,2) from com.adobe.cq.commerce.cq-commerce-core (257)
com.adobe.cq.commerce.common,version=[1.2,2) -- Cannot be resolved

Thanks

~S
 

Avatar

Avatar

samery56615784

Avatar

samery56615784

samery56615784

16-08-2016

We also tried with below dependency in 6.2 but still samer error

  1. <dependency>
  2. <groupId>com.adobe.cq.commerce</groupId>
  3. <artifactId>cq-commerce-core</artifactId>
  4. <version>5.14.102</version>
  5. <scope>provided</scope>
  6. </dependency>

com.adobe.cq.commerce.api,version=[1.2,2) -- Cannot be resolved

 

Any idea what we are missing?

Avatar

Avatar

samery56615784

Avatar

samery56615784

samery56615784

24-08-2016

samery56615784 wrote...

We also tried with below dependency in 6.2 but still samer error

  1. <dependency>
  2. <groupId>com.adobe.cq.commerce</groupId>
  3. <artifactId>cq-commerce-core</artifactId>
  4. <version>5.14.102</version>
  5. <scope>provided</scope>
  6. </dependency>

com.adobe.cq.commerce.api,version=[1.2,2) -- Cannot be resolved

 

Any idea what we are missing?

 

It is working in 6.2 (included 6.2.0 uber.jar) and also in 6.0 as well.

However we need it in to 6.1.0. it was not working in 6.1.0 . Should we include the uber.jar(6.1.0 version)?

Thanks

~S