AEM forms Guide Localization Service runmode configuration is not binding.

Avatar

Avatar
Level 1
thapliyal_neha
Level 1

Likes

0 likes

Total Posts

1 post

Correct reply

0 solutions
View profile

Avatar
Level 1
thapliyal_neha
Level 1

Likes

0 likes

Total Posts

1 post

Correct reply

0 solutions
View profile
thapliyal_neha
Level 1

27-09-2020

Hi,

 

I am trying to create a runmode configuration for OOB Guide Localizaton Service.

I have created the sling:OsgiConfig node inside the config folder of my project as "com.adobe.aemds.guide.service.GuideLocalizationService"  and added both the multivalue properties

"Localizable Properties"  and "supportedLocales"

but the configuration is not getting binded.

Is anybody having idea why existing configuration is not getting updated

 

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar
Give Back 3
MVP
Manjunath_K
MVP

Likes

140 likes

Total Posts

188 posts

Correct reply

61 solutions
Top badges earned
Give Back 3
Give Back
Boost 50
Boost 5
Boost 3
View profile

Avatar
Give Back 3
MVP
Manjunath_K
MVP

Likes

140 likes

Total Posts

188 posts

Correct reply

61 solutions
Top badges earned
Give Back 3
Give Back
Boost 50
Boost 5
Boost 3
View profile
Manjunath_K
MVP

27-09-2020

@thapliyal_neha 

 

Try below specified run mode config xml & this config will be picked.

 

Config file name should be :  Guide Localization Service.xml 

 

<?xml version="1.0" encoding="UTF-8"?>
<jcr:root xmlns:sling="http://sling.apache.org/jcr/sling/1.0" xmlns:cq="http://www.day.com/jcr/cq/1.0" xmlns:jcr="http://www.jcp.org/jcr/1.0"
jcr:primaryType="sling:OsgiConfig"
supportedLocales="[en,fr]"
Localizable_x0020_Properties="[custom]"/>

 

 

 

This config will be picked based on run mode & visible in Configuration Manager :

 

guide1.PNG

Answers (0)