AEM Eclipse Dev Tools Install Bundle Failing (MAC -Eclipse -AEM6.5.4 - Dev-Tools -WKND Project)

Avatar

Avatar
Level 1
rajakumare1
Level 1

Likes

0 likes

Total Posts

5 posts

Correct reply

0 solutions
View profile

Avatar
Level 1
rajakumare1
Level 1

Likes

0 likes

Total Posts

5 posts

Correct reply

0 solutions
View profile
rajakumare1
Level 1

01-02-2021

Hi, I  am leaning AEM and  I completed the local setup with AEM DEv Toold in Eclipse as mentioned in the wknd guide.

 

The content and apps folder are syncing correctly but the core bundle is not syncing when I make a change. It is throwing the below error. Can anyone please help. Thanks!!

 

Failed installing bundle : Unable to install/update bundle from dir /Users/b25838/Eclipseworkspaces/AEM-WKND/aem-guides-wknd/core/target/classes : Unable to resolve aem-guides-wknd.core [588](R 588.56): missing requirement [aem-guides-wknd.core [588](R 588.56)] osgi.wiring.package; (&(osgi.wiring.package=com.day.cq.search)(version>=1.4.0)(!(version>=2.0.0))) Unresolved requirements: [[aem-guides-wknd.core [588](R 588.56)] osgi.wiring.package; (&(osgi.wiring.package=com.day.cq.search)(version>=1.4.0)(!(version>=2.0.0)))]

Unable to install/update bundle from dir /Users/b25838/Eclipseworkspaces/AEM-WKND/aem-guides-wknd/core/target/classes : Unable to resolve aem-guides-wknd.core [588](R 588.56): missing requirement [aem-guides-wknd.core [588](R 588.56)] osgi.wiring.package; (&(osgi.wiring.package=com.day.cq.search)(version>=1.4.0)(!(version>=2.0.0))) Unresolved requirements: [[aem-guides-wknd.core [588](R 588.56)] osgi.wiring.package; (&(osgi.wiring.package=com.day.cq.search)(version>=1.4.0)(!(version>=2.0.0)))]

Accepted Solutions (0)

Answers (2)

Answers (2)

Avatar

Avatar
Establish
MVP
Anudeep_Garnepudi
MVP

Likes

275 likes

Total Posts

320 posts

Correct reply

87 solutions
Top badges earned
Establish
Ignite 1
Give Back 5
Give Back 3
Give Back 10
View profile

Avatar
Establish
MVP
Anudeep_Garnepudi
MVP

Likes

275 likes

Total Posts

320 posts

Correct reply

87 solutions
Top badges earned
Establish
Ignite 1
Give Back 5
Give Back 3
Give Back 10
View profile
Anudeep_Garnepudi
MVP

01-02-2021

@rajakumare1 

Check the version of your uber.jar and your AEM version are same or not.

Avatar

Avatar
Springboard
Level 7
KiranVedantam1992
Level 7

Likes

195 likes

Total Posts

213 posts

Correct reply

60 solutions
Top badges earned
Springboard
Give Back 5
Ignite 1
Affirm 50
Validate 1
View profile

Avatar
Springboard
Level 7
KiranVedantam1992
Level 7

Likes

195 likes

Total Posts

213 posts

Correct reply

60 solutions
Top badges earned
Springboard
Give Back 5
Ignite 1
Affirm 50
Validate 1
View profile
KiranVedantam1992
Level 7

01-02-2021

Hi @rajakumare1,

 

As you can see the error, there is a dependency version mismatch. Check this bundle com.day.cq.search installed in your local system and upgrade if needed.

 

Check my comments here on how to do it.

 

Hope this helps.

 

Thanks,

Kiran Vedantam.