AEM Author 6.5.3 changes in JSP shown in client browser

Avatar

Avatar

Eric_Stricker

Avatar

Eric_Stricker

Eric_Stricker

14-01-2020

I found this issue with AEM 6.5.3.

 

Having a custom component under Apps. Change the widget.jsp and the change in the jsp is NOT captured in the refresh page when added a simple static div

<div>testing</div>

 

Edit the adaptive form and it is captured, but "localhost:4502/content/forms/.../.../...html?wcmmode=disabled" is not reflecting the change.

 

On author (Windows based instance)

1. /libs/granite/ui/content/dumplibs.rebuild.html ==> Not working (both options)

2. for file system, find bundle.../data/classes and delete "classes" folder ==> Not working

    (Note: we tried this with the bundle staying as "active" as well as stopping the bundle before the delete of the folder)

3. for file system, find bundle.../data/outputcache and delete "outputcache" folder ==> Not working

    (Note: we tried this with the bundle staying as "active" as well as stopping the bundle before the delete of the folder)

4. Clear browser cache ==> Not working

 

Any combination of the above ==> Not working

 

Only thing that made it work ==> Restart Author.

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar

jbrar

Employee

Avatar

jbrar

Employee

jbrar
Employee

15-01-2020

Hey Eric,

 

Jsp's are cached under the fsclassloader. Can you clear everything at [1] and check if you get the updated data?

 

[1] http://<host>:<port>/system/console/fsclassloader 

Answers (0)