AEM 6.5 issue

Avatar

Avatar

rohand104

Avatar

rohand104

rohand104

20-09-2019

I'm trying to run AEM 6.5 and this is what i am getting

com.day.cq.dam.commons.util,version=[1.50,2) -- Cannot be resolved

There is no content

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar

Umesh_Sondhi

MVP

Avatar

Umesh_Sondhi

MVP

Umesh_Sondhi
MVP

20-09-2019

You can add the maven dependency in your pom.xml and build and install the code in AEM

<dependency>
  <groupId>com.day.cq.dam</groupId>
  <artifactId>cq-dam-commons</artifactId>
  <version>5.6.6</version>
  <scope>provided</scope>
</dependency>

check if the issue still persist.

Answers (3)

Answers (3)

Avatar

Avatar

Ankur_Khare

MVP

Avatar

Ankur_Khare

MVP

Ankur_Khare
MVP

09-10-2019

Could you please check the version of com.day.cq.dam coming from uber jar (check uber jar for 6.5).

And also check in your pom.xml files anywhere you might have added dependency for com.day.cq.dam the version for com.day.cq.dam should be same as uber jar.

Avatar

Avatar

ronnyfm

Avatar

ronnyfm

ronnyfm

09-10-2019

I agree, but even using the dependecy returned by depfinder,

<dependency>

    <artifactId>cq-dam-commons</artifactId>

    <version>5.12.54</version>

    <groupId>com.day.cq.dam</groupId>

    <scope>provided</scope>

</dependency>

I am getting the same exception.

Avatar

Avatar

jbrar

Employee

Avatar

jbrar

Employee

jbrar
Employee

20-09-2019

Uber jar for 6.5 should already have "com.day.cq.dam" embedded. I would recommend using uber-jar instead of adding manual dependencies. More details at [1]

[1]  How to Build AEM Projects using Apache Maven