AEM 6.5.6 - Bundles installed with dependencies fail but active

Avatar

Avatar
Ignite 1
Level 2
abcr1
Level 2

Likes

3 likes

Total Posts

27 posts

Correct reply

0 solutions
Top badges earned
Ignite 1
Give Back 5
Give Back 3
Give Back
Boost 3
View profile

Avatar
Ignite 1
Level 2
abcr1
Level 2

Likes

3 likes

Total Posts

27 posts

Correct reply

0 solutions
Top badges earned
Ignite 1
Give Back 5
Give Back 3
Give Back
Boost 3
View profile
abcr1
Level 2

08-10-2020

Hello,

I am working on AEM 6.5.6 and I have a bundle on installed state with missing dependency, but it is active on my console. I can not active it, any idea?

 

abcr1_1-1602142471309.png

 

Dependency is active:

abcr1_2-1602142604458.png

 

On another instance (same AEM), both are active. I have tried to reinstall in another order, but I can not active it. 

Thanks.

 

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar
Establish
MVP
santhosh_kumark
MVP

Likes

99 likes

Total Posts

111 posts

Correct reply

38 solutions
Top badges earned
Establish
Validate 1
Give Back 3
Give Back
Boost 50
View profile

Avatar
Establish
MVP
santhosh_kumark
MVP

Likes

99 likes

Total Posts

111 posts

Correct reply

38 solutions
Top badges earned
Establish
Validate 1
Give Back 3
Give Back
Boost 50
View profile
santhosh_kumark
MVP

08-10-2020

Hi @abcr1 ,

 

Try to resolve the osgiresourcelocator dependency with version 2.4.3.

Answers (1)

Answers (1)

Avatar

Avatar
Validate 1
Level 2
ektaa69139387
Level 2

Likes

8 likes

Total Posts

13 posts

Correct reply

2 solutions
Top badges earned
Validate 1
Give Back
Boost 5
Boost 3
Boost 1
View profile

Avatar
Validate 1
Level 2
ektaa69139387
Level 2

Likes

8 likes

Total Posts

13 posts

Correct reply

2 solutions
Top badges earned
Validate 1
Give Back
Boost 5
Boost 3
Boost 1
View profile
ektaa69139387
Level 2

08-10-2020

Please check the dependency version you are referring to it's 1.0,2 and the active version of that dependency is  2.4.0

ektaa69139387_0-1602144459325.png

So, please use the same version or install the required version.