AEM 6.4 Setup with Eclipse on windows

shridhar_sahu 20-01-2019

Hi,

I want to do a proper setup of AEM  6.4 with Eclipse also for syncing content form crx to local repo i will be using vaultClipse(not through command prompt). Can anyone please let me know in details working version:

  1. Which Eclipse version should i use(kepler, neon, other)?
  2. Version of AEM Developer Tools used as a installed software in eclipse(The Eclipse Project Updates - http://download.eclipse.org/eclipse/updates/4.4 or 4.5 or  other)?
  3. Version of vaultClipse(2.4.40 or other)?

Thanks,

Shridhar

Accepted Solutions (1)

Accepted Solutions (1)

gauravb41175071
MVP
21-01-2019

All versions of eclipse work fine, use the latest version from site to avoid any patches on old versions  -https://www.eclipse.org/downloads/

Use the latest version -

https://eclipse.adobe.com/aem/dev-tools/

No need to vaultclipse when you configure AEM Developer tool. You can set up server configurations in eclipse and automate the sync process between your filesystem and CRX

Answers (1)

Answers (1)

Ratna_Kumar
MVP
21-01-2019

Hi Shridhar,

1. You can use any version of Eclipse, but it should be Latest version which must be compatible to latest AEM version.

2. If you install AEM developer tool in eclipse, then no need to use VaultEclipse.

See this WKND tutorial for better understanding from Scratch: Getting Started with AEM Sites Chapter 1 - Project Setup

Hope this helps!!

Thanks,

Ratna Kumar.