AEM 6.4 rich text editor-- not able to change list type when a list type has already been applied to text

Avatar

Avatar
Validate 1
Level 2
sundarig9086821
Level 2

Likes

10 likes

Total Posts

28 posts

Correct reply

1 solution
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 10
Boost 1
View profile

Avatar
Validate 1
Level 2
sundarig9086821
Level 2

Likes

10 likes

Total Posts

28 posts

Correct reply

1 solution
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 10
Boost 1
View profile
sundarig9086821
Level 2

07-01-2019

Hi,

I am not able to change the list type when it is applied already for selected text.

EX: we retail site text component

1662108_pastedImage_0.png

When the bullet list has given to text sample1 we are not able to change to numbered list and paragraph formatting options has also been disabled.

Whereas both works fine for normal text.

1662109_pastedImage_1.png

Thanks in advance!!!

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar
Validate 25
Level 10
smacdonald2008
Level 10

Likes

1,410 likes

Total Posts

12,671 posts

Correct reply

2,278 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Give back 900
Give back 600
View profile

Avatar
Validate 25
Level 10
smacdonald2008
Level 10

Likes

1,410 likes

Total Posts

12,671 posts

Correct reply

2,278 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Give back 900
Give back 600
View profile
smacdonald2008
Level 10

09-01-2019

I would log a bug for this so it can be fixed.

Answers (11)

Answers (11)

Avatar

Avatar
Coach
MVP
Arun_Patidar
MVP

Likes

1,462 likes

Total Posts

3,328 posts

Correct reply

949 solutions
Top badges earned
Coach
Contributor 2
Ignite 10
Give Back 700
Boost 1000
View profile

Avatar
Coach
MVP
Arun_Patidar
MVP

Likes

1,462 likes

Total Posts

3,328 posts

Correct reply

949 solutions
Top badges earned
Coach
Contributor 2
Ignite 10
Give Back 700
Boost 1000
View profile
Arun_Patidar
MVP

08-01-2019

Hi,

I tried for weretail/components/content/text

chrome-capture.gif

Avatar

Avatar
Validate 1
Level 2
sundarig9086821
Level 2

Likes

10 likes

Total Posts

28 posts

Correct reply

1 solution
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 10
Boost 1
View profile

Avatar
Validate 1
Level 2
sundarig9086821
Level 2

Likes

10 likes

Total Posts

28 posts

Correct reply

1 solution
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 10
Boost 1
View profile
sundarig9086821
Level 2

09-01-2019

Hi,

Yes, we are facing issues in default plugin.

We are able to see the below plugins:

1663729_pastedImage_0.png

Thanks,
Sundari

Avatar

Avatar
Coach
MVP
Arun_Patidar
MVP

Likes

1,462 likes

Total Posts

3,328 posts

Correct reply

949 solutions
Top badges earned
Coach
Contributor 2
Ignite 10
Give Back 700
Boost 1000
View profile

Avatar
Coach
MVP
Arun_Patidar
MVP

Likes

1,462 likes

Total Posts

3,328 posts

Correct reply

949 solutions
Top badges earned
Coach
Contributor 2
Ignite 10
Give Back 700
Boost 1000
View profile
Arun_Patidar
MVP

09-01-2019

Hi,

How many plugins you can see when you did not added rtePlugin node(default plugins)?

When you did not add uiSettings and retPlugins nodes, default plugins will be added.

Avatar

Avatar
Validate 1
Level 2
sundarig9086821
Level 2

Likes

10 likes

Total Posts

28 posts

Correct reply

1 solution
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 10
Boost 1
View profile

Avatar
Validate 1
Level 2
sundarig9086821
Level 2

Likes

10 likes

Total Posts

28 posts

Correct reply

1 solution
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 10
Boost 1
View profile
sundarig9086821
Level 2

09-01-2019

Hi arunpatidar26​/ smacdonald2008​,

Thanks for the update..

This has fixed the issue..

However, when i add in dialog field with a sling:resourceType=cq/gui/components/authoring/dialog/richtext  

with no rteplugin as child nodes the list functionality is not working.

It works fine in 6.1 not in 6.4.

1663727_pastedImage_1.png

When i use this component in page:

1663728_pastedImage_2.png

Once i give the list type i am not able to change it.

However if i add rteplugin from /apps/core/wcm/components/text/v2/text/cq:dialog/content/items/tabs/items/properties/items/columns/items/column/items/text/rtePlugins it works fine.

Any idea on this?

Avatar

Avatar
Validate 25
Level 10
smacdonald2008
Level 10

Likes

1,410 likes

Total Posts

12,671 posts

Correct reply

2,278 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Give back 900
Give back 600
View profile

Avatar
Validate 25
Level 10
smacdonald2008
Level 10

Likes

1,410 likes

Total Posts

12,671 posts

Correct reply

2,278 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Give back 900
Give back 600
View profile
smacdonald2008
Level 10

08-01-2019

Excellent reply and use of video here!

Avatar

Avatar
Validate 1
Level 2
sundarig9086821
Level 2

Likes

10 likes

Total Posts

28 posts

Correct reply

1 solution
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 10
Boost 1
View profile

Avatar
Validate 1
Level 2
sundarig9086821
Level 2

Likes

10 likes

Total Posts

28 posts

Correct reply

1 solution
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 10
Boost 1
View profile
sundarig9086821
Level 2

08-01-2019

Hi,

The issue exists for both /libs/foundation/components/text & weretail/components/content/text.

And there is no error in console related to this.

Avatar

Avatar
Coach
MVP
Arun_Patidar
MVP

Likes

1,462 likes

Total Posts

3,328 posts

Correct reply

949 solutions
Top badges earned
Coach
Contributor 2
Ignite 10
Give Back 700
Boost 1000
View profile

Avatar
Coach
MVP
Arun_Patidar
MVP

Likes

1,462 likes

Total Posts

3,328 posts

Correct reply

949 solutions
Top badges earned
Coach
Contributor 2
Ignite 10
Give Back 700
Boost 1000
View profile
Arun_Patidar
MVP

07-01-2019

Can you please let me know which component are you using? Is there an error in browser console?

Avatar

Avatar
Validate 1
Level 2
sundarig9086821
Level 2

Likes

10 likes

Total Posts

28 posts

Correct reply

1 solution
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 10
Boost 1
View profile

Avatar
Validate 1
Level 2
sundarig9086821
Level 2

Likes

10 likes

Total Posts

28 posts

Correct reply

1 solution
Top badges earned
Validate 1
Boost 5
Boost 3
Boost 10
Boost 1
View profile
sundarig9086821
Level 2

07-01-2019

Hi Arun,

Thanks for the reply..

If i try i full mode also i have similar issue.

For ex: if i open the OOTB text component dialog in full mode and type a text "sample1" and when i select the text andclick on numbered or bullet icon nothing happens.

1662460_pastedImage_0.png

Avatar

Avatar
Validate 25
MVP
Ratna_Kumar
MVP

Likes

159 likes

Total Posts

755 posts

Correct reply

134 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Give Back 50
Give Back 5
View profile

Avatar
Validate 25
MVP
Ratna_Kumar
MVP

Likes

159 likes

Total Posts

755 posts

Correct reply

134 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Give Back 50
Give Back 5
View profile
Ratna_Kumar
MVP

07-01-2019

Yes. I agree with Arun. It works in full mode of the dialog.

1662129_pastedImage_0.png

Thanks,

Ratna Kumar

Avatar

Avatar
Validate 25
Level 10
smacdonald2008
Level 10

Likes

1,410 likes

Total Posts

12,671 posts

Correct reply

2,278 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Give back 900
Give back 600
View profile

Avatar
Validate 25
Level 10
smacdonald2008
Level 10

Likes

1,410 likes

Total Posts

12,671 posts

Correct reply

2,278 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Give back 900
Give back 600
View profile
smacdonald2008
Level 10

07-01-2019

As Arun suggests - try to maximize the window.

Avatar

Avatar
Coach
MVP
Arun_Patidar
MVP

Likes

1,462 likes

Total Posts

3,328 posts

Correct reply

949 solutions
Top badges earned
Coach
Contributor 2
Ignite 10
Give Back 700
Boost 1000
View profile

Avatar
Coach
MVP
Arun_Patidar
MVP

Likes

1,462 likes

Total Posts

3,328 posts

Correct reply

949 solutions
Top badges earned
Coach
Contributor 2
Ignite 10
Give Back 700
Boost 1000
View profile
Arun_Patidar
MVP

07-01-2019

Hi,

Can you try in maximise mode. I am able to do there. I tried with OOTB Text components

Screenshot 2019-01-07 at 7.22.51 PM.png