AEM 6.4 - No overlay in Edit or Design more

Avatar

Avatar

jamiec4451712

Avatar

jamiec4451712

jamiec4451712

18-06-2018

I'm updating an AEM application from 6.2 to 6.4. After the update, things are working normally. However, in edit mode and design mode, there is no overlay, hover states, or drag and drop areas. I can't edit anything, no components show up in the sidekick or the content tree, and I can't use design mode to update the settings for the page or parsys, because there is no overlay there either. Basically, there is no way for me to interact with the page via edit, design, or targeting mode. I'm wondering if anyone has any ideas as to what could be the cause. It's not even that I can't add a component to a parsys - the "drag components here" is not even there. Nothing highlights as I mouse over, etc.

- I am admin, so it's not permissions related

- The default design nodes look fine for these pages and components

- I tried creating design dialogs for the components, but those don' work either

- The components all show up under /libs/wcm/core/content/sites/components.html and they look fine

- All bundles are started

- The website works completely normally otherwise

Any ideas?

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar

Ravi_Pampana

MVP

Avatar

Ravi_Pampana

MVP

Ravi_Pampana
MVP

24-08-2018

I faced similar issue while upgrading from AEM 6.2 to AEM 6.4. Pages loading fine in preview mode but in edit mode page is blank and not able to edit any component/add components. After lot of debug found there is exception (see view source in edit mode and you might see some exception) in one of the jsp which is reading property using jcrResourceResolver and calling login administrator in backend. In AEM 6.4 bundles using login administration will throw exception as we need to update to system user while reading/modifying jcr nodes.

After fixing the exception, in edit mode page loaded fine and got parsys to add components.

Answers (1)

Answers (1)

Avatar

Avatar

davids82599546

Avatar

davids82599546

davids82599546

24-08-2018

Hey,

We have 2 notes for AEM 6.4. that explain your question:

Note:

Design mode is only available for static templates. Templates that are created with editable templates should be edited using the template editor.

Note:

Design mode is only available for design configurations stored as content under (/etc).

Starting in AEM 6.4, it is recommended to store designs as configuration data under /apps to support continuous deployment scenarios. Designs stored under /apps are not editable at runtime and the Design mode will not be available to non-admin users for such templates.

You can see here the link with this information: Configuring Components in Design Mode

I hope that this help you.