AEM 6.4 Internal redirects not working

Avatar

Avatar

Arun_007

Avatar

Arun_007

Arun_007

02-01-2020

Hi All,

 

Happy new Year.

I am trying to configure the internal redirects in AEM 6.4 publishers. The requirement is to redirect the base url to the correct landing page.

 

I have done the below things:

1. created map.publish.env nodes under /etc with the sling:match and sling:internalRedirect values.

2. verified the "Apache Sling Resource Resolver Factory" in configMgr for correct node being provided for the mapping

3. In the jcrresolver /system/console/jcrresolver, I have verified below:

    Namespace Mangling - Enabled

    Mapping Location - map.publish.env

    Configuration Test is also successfully resolving the url to the specific path.

 

But after this during the testing of the url in browser, It says below:

    The requested URL / was not found on this server.

 

Could someone please help me if am missing something? It would be very helpful.

 

Thanks,

Arun.

 

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar

jbrar

Employee

Avatar

jbrar

Employee

jbrar
Employee

06-01-2020

Can you check if the mapping was actually applied by AEM:

 

- Go to http://<host>:<port>/system/console/jcrresolver

- Under "Mapping Map Entries", check if the entries are appearing there.

 

You can also setup a DEBUG logger on "org.apache.sling.resourceresolver" to check how the resolution is happening and which resource resolver settings are being applied.

Answers (1)

Answers (1)

Avatar

Avatar

Jörg_Hoh

Employee

Total Posts

3.0K

Likes

910

Correct Answer

1.0K

Avatar

Jörg_Hoh

Employee

Total Posts

3.0K

Likes

910

Correct Answer

1.0K
Jörg_Hoh
Employee

03-01-2020

My best guess is that it's a permission thing. Login with "admin" via CRXDE and then do the same request again to validate this assumption.