Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

AEM 6.4 DAM Update Asset Workflow: Thumbnails Not Generated For application/octet-stream MIME Type

Avatar

Avatar
Ignite 1
Level 1
Praveen_Kasaraj
Level 1

Like

1 like

Total Posts

10 posts

Correct Reply

0 solutions
Top badges earned
Ignite 1
Give Back 3
Give Back
Boost 1
View profile

Avatar
Ignite 1
Level 1
Praveen_Kasaraj
Level 1

Like

1 like

Total Posts

10 posts

Correct Reply

0 solutions
Top badges earned
Ignite 1
Give Back 3
Give Back
Boost 1
View profile
Praveen_Kasaraj
Level 1

16-08-2019

#DearAEM Experts,

We are migrating DAM content from 6.1 to 6.4 and most of the existing DAM images in 6.1 have jcr:mimeType as application/octet-stream.
(Ex: /content/dam/projects/we-retail/cover/jcr:content/renditions/original/jcr:content)
Issue: AEM6.4 DAM Asset Update Workflow does not generate thumbnails for images having jcr:mimeType (application/octet-stream) but AEM 6.1 does.

Expected: AEM6.4 DAM Asset Update Workflow should generate thumbnails for 'application/octet-stream' mime type images.

Please refer to "jcr:mimeType" property, if you change from application/octet-stream to image/png and re-run the Update Asset workflow the thumbnail images are generated.

Screenshot 2019-08-16 at 4.19.21 PM.png

Note: Applied AEM 6.4.3 service pack.

Any workaround would be helpful, apart from writing script to update jcr:mimeType from 'application/octet-stream' to 'image/jpeg' (image/jpeg, image/jpg, image/png, image/gif, tiff, etc.,).

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar
Coach
Employee
Jörg_Hoh
Employee

Likes

1,118 likes

Total Posts

3,149 posts

Correct Reply

1,073 solutions
Top badges earned
Coach
Give back 600
Ignite 5
Ignite 3
Ignite 1
View profile

Avatar
Coach
Employee
Jörg_Hoh
Employee

Likes

1,118 likes

Total Posts

3,149 posts

Correct Reply

1,073 solutions
Top badges earned
Coach
Give back 600
Ignite 5
Ignite 3
Ignite 1
View profile
Jörg_Hoh
Employee

19-08-2019

Seems you already contacted Adobe support and are waiting for a solution. I am not aware of any other workaround than to write a script to change the mimeType.

Answers (2)

Answers (2)

Avatar

Avatar
Give Back 5
Employee
yanirac19051392
Employee

Likes

20 likes

Total Posts

38 posts

Correct Reply

7 solutions
Top badges earned
Give Back 5
Give Back 3
Give Back 10
Give Back
Boost 5
View profile

Avatar
Give Back 5
Employee
yanirac19051392
Employee

Likes

20 likes

Total Posts

38 posts

Correct Reply

7 solutions
Top badges earned
Give Back 5
Give Back 3
Give Back 10
Give Back
Boost 5
View profile
yanirac19051392
Employee

16-08-2019

Can you test in AEM6.5?  I found an issue was resolved in AEM6.5 which may be the same.  If you still have issues in 6.5 it will be good to setup debug for workflow and perhaps open a Daycare ticket. 

Avatar

Avatar
Ignite 1
Level 1
Praveen_Kasaraj
Level 1

Like

1 like

Total Posts

10 posts

Correct Reply

0 solutions
Top badges earned
Ignite 1
Give Back 3
Give Back
Boost 1
View profile

Avatar
Ignite 1
Level 1
Praveen_Kasaraj
Level 1

Like

1 like

Total Posts

10 posts

Correct Reply

0 solutions
Top badges earned
Ignite 1
Give Back 3
Give Back
Boost 1
View profile
Praveen_Kasaraj
Level 1

18-08-2019

Thanks for your response.

Yes, AEM 6.5 it works and I am aware of that. We are using AEM 6.4 version and seeking a solution or a workaround till DayCare resolves this issue.

Jörg Hoh​ can you please help me on this?