Highlighted

AEM 6.4 authoring issue - frame of component dialog is not wide enough

Avatar

Avatar

Luc_Rochefort

Avatar

Luc_Rochefort

Luc_Rochefort

19-10-2018

Hi!

After upgrading my local 6.2 instance to 6.4, I tried to do some authoring to make sure everything is o.k.

I noticed that when I open a component's dialog, a frame opens but it is not wide enough to let me move the dialog further to the right.

Please have a look at the video:

Thanks

Replies

Highlighted

Avatar

Avatar

Luc_Rochefort

Avatar

Luc_Rochefort

Luc_Rochefort

19-10-2018

Hi!

I see a CSS rule applied to the dialog coming from:

http://localhost:4502/libs/cq/gui/components/authoring/editors/clientlibs/sites/page.03f0deffa109172...

This rule is breaking the display:

.cq-dialog-floating{width:800px !important;}

Has someone else seen  this ?

Highlighted

Avatar

Avatar

smacdonald2008

Total Posts

12.7K

Likes

1.4K

Correct Answer

2.3K

Avatar

smacdonald2008

Total Posts

12.7K

Likes

1.4K

Correct Answer

2.3K
smacdonald2008

19-10-2018

This certainly looks like a update issue. A Dialog should appear like this -

RTE11.png

Can you test on a fresh AEM instance and see if you experience this. You may need a hotfix so I recommend checking with the support team on this.

Highlighted

Avatar

Avatar

Luc_Rochefort

Avatar

Luc_Rochefort

Luc_Rochefort

19-10-2018

Hi!

I thought about the hotfix issue, so I just installed Service pack 2. Unfortunately, it did not solve the CSS issue.

I'll try on a fresh 6.4 and I'll keep you posted.

Thank you.

Highlighted

Avatar

Avatar

Luc_Rochefort

Avatar

Luc_Rochefort

Luc_Rochefort

19-10-2018

smacdonald2008

Hi!

I reinstalled 6.4 GA (barebones, no service pack) and the authoring is fine. The dialog opens up as it should.

I had a look at the CSS, and the rule I mentioned earlier is not there.

So, I believe that some hotfix, not included in SP2, is missing from the upgrade process.

What do you think?

Highlighted

Avatar

Avatar

smacdonald2008

Total Posts

12.7K

Likes

1.4K

Correct Answer

2.3K

Avatar

smacdonald2008

Total Posts

12.7K

Likes

1.4K

Correct Answer

2.3K
smacdonald2008

19-10-2018

Yes - i expect on Fresh instance - this will not occur.

Highlighted

Avatar

Avatar

smacdonald2008

Total Posts

12.7K

Likes

1.4K

Correct Answer

2.3K

Avatar

smacdonald2008

Total Posts

12.7K

Likes

1.4K

Correct Answer

2.3K
smacdonald2008

19-10-2018

There is something in that process that caused this. You are correct - looks like something interfered with the CSS,