Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

AEM 6.3 - not add component to parsys

Avatar

Avatar
Validate 1
Level 1
dangl95641558
Level 1

Likes

0 likes

Total Posts

9 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Ignite 1
View profile

Avatar
Validate 1
Level 1
dangl95641558
Level 1

Likes

0 likes

Total Posts

9 posts

Correct Reply

0 solutions
Top badges earned
Validate 1
Ignite 1
View profile
dangl95641558
Level 1

25-03-2018

Hi All,

I am creating a parsys template that permits to add my some custom components so we can make changes from the front end interface.

This is my code

...

<body class="${currentPage.template.name}">

   <p>Parsys here</p>

   <sly data-sly-resource="${'par_1' @ resourceType='wcm/foundation/components/parsys'}"/>

   <sly data-sly-include="customfooterlibs.html" data-sly-unwrap/>

   <p>end - page</p>

</body>

...

I do not know the reason why it is neither able to drag nor drop any components to this parsys in edit mode. The symbol of adding does not exist and no components available.

1450984_pastedImage_3.png

Please help me point out the reasons of error and solutions to fix this.

Thanks

-Dan

View Entire Topic

Avatar

Avatar
Validate 1
Level 2
dylanr72808383
Level 2

Likes

3 likes

Total Posts

18 posts

Correct Reply

3 solutions
Top badges earned
Validate 1
Boost 3
Boost 1
Affirm 3
Affirm 1
View profile

Avatar
Validate 1
Level 2
dylanr72808383
Level 2

Likes

3 likes

Total Posts

18 posts

Correct Reply

3 solutions
Top badges earned
Validate 1
Boost 3
Boost 1
Affirm 3
Affirm 1
View profile
dylanr72808383
Level 2

26-03-2018

Probably because AEM doesn't know which components to allow on your parsys. Please check the following links on how to do it in design mode and how to do it in xml format in the design of your project

Configuring Components in Design Mode

cq5 - Restrict the components in AEM 5.6.1 - Stack Overflow