AEM 6.2 - Missing element AD in element OCD

Avatar

Avatar

sandeepk1310028

Avatar

sandeepk1310028

sandeepk1310028

30-03-2017

We are getting following errors in error.log. Any idea what these errors are and how to fix them ?

Missing element AD in element OCD : bundle://469.0:0/OSGI-INF/metatype/com.adobe.acs.commons.wcm.properties.shared.impl.SharedComponentPropertiesImpl.xmlorg.apache.felix.metatype

[ERROR]

Wed, Mar 29 2017 
17:39:19 MDT

Missing element AD in element OCD : bundle://469.0:0/OSGI-INF/metatype/com.adobe.acs.commons.rewriter.impl.StylesheetInlinerTransformerFactory.xmlorg.apache.felix.metatype

[ERROR]

Wed, Mar 29 2017 
17:39:19 MDT

Missing element AD in element OCD : bundle://468.0:0/OSGI-INF/metatype/com.adobe.forms.test.service.impl.FormDataXMLProviderRegistryImpl.xmlorg.apache.felix.metatype

[ERROR]

Wed, Mar 29 2017 
17:39:19 MDT

Missing element AD in element OCD : bundle://434.0:0/OSGI-INF/metatype/com.adobe.cq.social.enablement.services.impl.EnablementSiteServiceImpl.xmlorg.apache.felix.metatype

[ERROR]

Wed, Mar 29 2017 
17:39:19 MDT

Missing element AD in element OCD : bundle://434.0:0/OSGI-INF/metatype/com.adobe.cq.social.enablement.services.impl.EnablementContentReplicationFilterFactory.xmlorg.apache.felix.metatype

[ERROR]

Wed, Mar 29 2017 
17:39:19 MDT

Missing element AD in element OCD : bundle://430.0:0/OSGI-INF/metatype/com.adobe.cq.social.user.impl.transport.HttpToPublisherImpl.xmlorg.apache.felix.metatype

[ERROR]

Wed, Mar 29 2017 
17:39:19 MDT

Missing element AD in element OCD : bundle://430.0:0/OSGI-INF/metatype/com.adobe.cq.social.user.endpoints.impl.UserProfileOperationService.xmlorg.apache.felix.metatype

[ERROR]

Wed, Mar 29 2017 
17:39:19 MDT

Missing element AD in element OCD : bundle://430.0:0/OSGI-INF/metatype/com.adobe.cq.social.user.endpoints.impl.CommunityUserOperationService.xmlorg.apache.felix.metatype

[ERROR]

Wed, Mar 29 2017 
17:39:19 MDT

Missing element AD in element OCD : bundle://430.0:0/OSGI-INF/metatype/com.adobe.cq.social.site.impl.SiteConfiguratorImpl.xmlorg.apache.felix.metatype

[ERROR]

Wed, Mar 29 2017 
17:39:19 MDT

Missing element AD in element OCD : bundle://430.0:0/OSGI-INF/metatype/com.adobe.cq.social.site.impl.AnalyticsComponentConfigurationServiceImpl.xmlorg.apache.felix.metatype

[ERROR]

Wed, Mar 29 2017 
17:39:19 MDT

Missing element AD in element OCD : bundle://430.0:0/OSGI-INF/metatype/com.adobe.cq.social.site.endpoints.impl.SiteOperationService.xmlorg.apache.felix.metatype

[ERROR]

Wed, Mar 29 2017 
17:39:19 MDT

Missing element AD in element OCD : bundle://420.0:0/OSGI-INF/metatype/com.adobe.cq.media.publishing.impl.servlets.OriginalImageServlet.xmlorg.apache.felix.metatype

[ERROR]

Wed, Mar 29 2017 
17:39:19 MDT

Missing element AD in element OCD : bundle://406.0:0/OSGI-INF/metatype/com.adobe.aemds.guide.cache.impl.DefaultCacheStoreProvider.xmlorg.apache.felix.metatype

[ERROR]

Wed, Mar 29 2017 
17:39:19 MDT

Missing element AD in element OCD : bundle://406.0:0/OSGI-INF/metatype/com.adobe.aemds.guide.cache.CacheManager.xmlorg.apache.felix.metatype

[ERROR]

Wed, Mar 29 2017 
17:39:19 MDT

Missing element AD in element OCD : bundle://283.0:0/OSGI-INF/metatype/com.day.cq.workflow.impl.CQPayloadMap.xmlorg.apache.felix.metatype

[ERROR]

Wed, Mar 29 2017 
17:39:19 MDT

Missing element AD in element OCD : bundle://283.0:0/OSGI-INF/metatype/com.day.cq.workflow.compatibility.ScriptContextProviderImpl.xmlorg.apache.felix.metatype

[ERROR]

Wed, Mar 29 2017 
17:39:19 MDT

Missing element AD in element OCD : bundle://283.0:0/OSGI-INF/metatype/com.day.cq.workflow.compatibility.CQWorkflowProcessRunner.xmlorg.apache.felix.metatype

View Entire Topic

Avatar

Avatar

fabianh12876403

Avatar

fabianh12876403

fabianh12876403

12-08-2019

I have the same Problem wit aem 6.4 and acs-commons 4.2.0.

I can't login with idp (saml login) anymore. And it's not possible to create any new form (aem-forms).

After uninstalling acs-commons 4.2.0 I can create new form (aem-forms), but idp login still not working.

Our luck is that the problem is just on the develop server. So we have a bit time to fix it.

But what will happen if we have the same on production system?

Log Message when creating a form (aem-forms)

12.08.2019 10:01:37.246 *ERROR* [10.240.33.41 [1565596897237] POST /content/dam/formsanddocuments/ HTTP/1.1] org.apache.sling.servlets.post.impl.operations.ModifyOperation Exception during response processing

.

org.apache.sling.api.resource.PersistenceException: Cannot copy ancestor /content/forms/af to descendant /content/forms/af

Log Message Missing element AD

12.08.2019 10:23:37.736 *ERROR* [qtp124151956-2511] org.apache.felix.metatype fromDocuments: Error accessing document bundle://586.0:0/OSGI-INF/metatype/metatype.properties : XML parsing exception while readi

ng metadata: Attr.value missing f. Role (position:START_TAG <LC Role='null'>@29:34 in bundle://586.0:0/OSGI-INF/metatype/metatype.properties)

12.08.2019 10:23:37.739 *ERROR* [qtp124151956-2511] org.apache.felix.metatype Missing element AD in element OCD : bundle://615.1:0/OSGI-INF/metatype/com.adobe.aemds.guide.addon.signing.echosign.impl.EchoSignS

erviceImpl.xml

12.08.2019 10:23:37.761 *WARN* [qtp124151956-2511] org.apache.jackrabbit.oak.query.QueryImpl Traversal query (query without index): select [jcr:path], [jcr:score], * from [nt:base] as a where [cq:componentPat

h] = 'fd/fmaddon/components/analytics/formanalytics' and isdescendantnode(a, '/etc/cloudservices/sitecatalyst') /* xpath: /jcr:root/etc/cloudservices/sitecatalyst//*[(@cq:componentPath = 'fd/fmaddon/component

s/analytics/formanalytics')] */; consider creating an index

12.08.2019 10:23:37.774 *ERROR* [qtp124151956-2511] org.apache.felix.metatype Missing element AD in element OCD : bundle://660.1:0/OSGI-INF/metatype/com.adobe.aemds.formset.service.impl.FormsetServiceImpl.xml

12.08.2019 10:23:37.780 *ERROR* [qtp124151956-2511] org.apache.felix.metatype Missing element AD in element OCD : bundle://677.0:0/OSGI-INF/metatype/com.adobe.fd.readerextensions.service.impl.ReaderExtensions

ServiceImpl.xml

12.08.2019 10:23:37.783 *ERROR* [qtp124151956-2511] org.apache.felix.metatype fromDocuments: Error accessing document bundle://694.1:0/OSGI-INF/metatype/com.adobe.forms.admin.impl.LCFormsAdminServiceImpl.prop

erties : XML parsing exception while reading metadata: unterminated entity ref (position:TEXT #Mon Nov 26 10:4...@7:155 in bundle://694.1:0/OSGI-INF/metatype/com.adobe.forms.admin.impl.LCFormsAdminServiceImpl

.properties)

And if I tried to login with ldap user via idp (saml login)

12.08.2019 10:22:39.835 *INFO* [qtp124151956-2511] org.apache.sling.auth.core.impl.SlingAuthenticator handleLoginFailure: Unable to authenticate null: UserId/Password mismatch.

12.08.2019 10:23:16.425 *ERROR* [10.240.33.41 [1565598196422] GET /home/users/{company}/SotwfBnHRxrDJw2jVJGj.preferences.json HTTP/1.1] com.day.cq.security.impl.AbstractHTMLResponseServlet Authorizable | com.adobe

.granite.security.user.internal.UserPropertiesImpl@4c848679

@kautuksahni​the link is not working anymore it's going just on the startpage, so it's useless. please update if it's helpful