Expand my Community achievements bar.

July 31st AEM Gems Webinar: Elevate your AEM development to master the integration of private GitHub repositories within AEM Cloud Manager.

AEM 6.2 is not Staring with windows service post upgrade from 5.6.1

Avatar

Level 2

Hi,

 

After upgrading the application to AEM 6.2, I am trying to start the instance with windows service but when I do this its corrupting my upgraded instance with "500 error thrown on browser".

 

Here are the different scenarios I have tried to debug this issue.

 

1. When I am starting the fresh AEM instance with windows service it is getting started and instance is working good.

2. When I am trying to start an upgraded AEM instance with windows service the instance is getting corrupted. I could see several data store exceptions in the error.log.

3. I have tried using different run modes appending "crx3,crx3tar" in the "crx-quickstart\opt\helpers\instsrv.bat" file but the same thing is going on.

4. Every time I  tried this with a fresh upgraded instance as the repository is been corrupted.

5. The same upgraded instances are working good with normal startup command i.e. java -Xmx4096m -XX:MaxPermSize=2048M -jar aem-author-p4502.jar -r author,crx3,crx3tar

 

Please let me know any one has solution for this

6 Replies

Avatar

Administrator

Can you please share with us the AEM error.log when starting the server as windows service?

~kautuk



Kautuk Sahni

Avatar

Level 2

Whether the attachment seems to be useful ? kautuksahni?

Avatar

Level 2

Hi Opkar,

 

Same thing I have tried it with . As I said in my description I have tried on fresh AEM 6.2 instance and its working fine. But when it comes to upgraded instance from 5.6.1 to 6.2, I am facing this issue.

May I know whether the same script gave good results for you when tried on upgraded instance ??

Regards,

Manikiran

Avatar

Level 10

There could be a bug somewhere - if a fresh instance works and not an upgraded AEM instance - looks like a bug, Please file a ticket so Support and Eng are aware of this issue.