Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

AEM 6.1 Uber jar

Avatar

Avatar
Validate 10
Level 3
vishwanath881
Level 3

Likes

9 likes

Total Posts

50 posts

Correct Reply

1 solution
Top badges earned
Validate 10
Validate 1
Boost 5
Boost 3
Boost 1
View profile

Avatar
Validate 10
Level 3
vishwanath881
Level 3

Likes

9 likes

Total Posts

50 posts

Correct Reply

1 solution
Top badges earned
Validate 10
Validate 1
Boost 5
Boost 3
Boost 1
View profile
vishwanath881
Level 3

07-04-2016

Hello Team,

We are using unobsfucated UberJar provided by Day care in our project. This jar is hosted in out local maven repository and we are including this as dependency in our pom.xml as shown below.

        <dependency>
              <groupId>com.adobe.aem</groupId>
              <artifactId>uber-jar</artifactId>
              <version>6.1.0-SP1</version>
        </dependency>

But, whenever I am building the code, the bundle is getting into resolved state. I see that it is complaining about lot of dependencies couple of them are com.adobe.cq.dam, com.adobe.cq.dam.s7imaging, com.adobe.cq.social,com.twelvemonkeys: and many more. It works perfectly fine for other members in my team, not sure why it doesn't in mine.

When I remove this dependency and use the obfuscated version shown below, everything looks good. But we want to use the unobsfuscated uberjar

<dependency>

<groupId>com.adobe.aem</groupId>

    <artifactId>uber-jar</artifactId>

    <version>6.1.0</version>

    <classifier>obfuscated-apis</classifier>

    <scope>provided</scope>

</dependency>

 

I deleted my m2 repository and pulled the jars again but still no result. I have also tried creating a fresh instance of AEM 6.1 with SP1 but nothing helps.

Replies

Avatar

Avatar
Validate 1
Level 2
kartheekd203042
Level 2

Likes

3 likes

Total Posts

19 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Ignite 1
Give Back 3
Give Back
Boost 3
View profile

Avatar
Validate 1
Level 2
kartheekd203042
Level 2

Likes

3 likes

Total Posts

19 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Ignite 1
Give Back 3
Give Back
Boost 3
View profile
kartheekd203042
Level 2

19-12-2016

     @vishwanath881b   The scope attribute should be provided in the snippet you pasted above similar to the obfuscated one.

Avatar

Avatar
Give Back 50
Employee
Feike_Visser1
Employee

Likes

247 likes

Total Posts

970 posts

Correct Reply

221 solutions
Top badges earned
Give Back 50
Give Back 5
Give Back 3
Give Back 25
Give Back 10
View profile

Avatar
Give Back 50
Employee
Feike_Visser1
Employee

Likes

247 likes

Total Posts

970 posts

Correct Reply

221 solutions
Top badges earned
Give Back 50
Give Back 5
Give Back 3
Give Back 25
Give Back 10
View profile
Feike_Visser1
Employee

19-12-2016

Is the version correct?

6.1 SP1 should use <version>6.1.0-SP1-B0001</version>

Avatar

Avatar
Validate 1
Level 2
kartheekd203042
Level 2

Likes

3 likes

Total Posts

19 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Ignite 1
Give Back 3
Give Back
Boost 3
View profile

Avatar
Validate 1
Level 2
kartheekd203042
Level 2

Likes

3 likes

Total Posts

19 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Ignite 1
Give Back 3
Give Back
Boost 3
View profile
kartheekd203042
Level 2

19-12-2016

 This is how we can use if we rename the jar  to uber-jar-6.1.0-apis.jar and place it under \\com\adobe\aem\uber-jar\6.1.0  in the local maven repository.
       

<dependency> <groupId>com.adobe.aem</groupId> <artifactId>uber-jar</artifactId> <version>6.1.0</version> <scope>provided</scope> <classifier>apis</classifier> </dependency>

@vishwanath881 please let me know if you have any issues post this or maybe you can even try what @Feike Visser suggested if you did not rename it.