AEM 5.6 : RTE Customization : Semantic markup map is not working to map <b> to <strong>

Avatar

Avatar
Validate 1
Level 1
chaitanya_pai1
Level 1

Like

1 like

Total Posts

4 posts

Correct reply

0 solutions
Top badges earned
Validate 1
Boost 1
View profile

Avatar
Validate 1
Level 1
chaitanya_pai1
Level 1

Like

1 like

Total Posts

4 posts

Correct reply

0 solutions
Top badges earned
Validate 1
Boost 1
View profile
chaitanya_pai1
Level 1

15-10-2015

 Hi,

We have a requirement to ensure that <b> are converted to <strong> and <i> are converted to <em> in RTE. I followed the instructions in the post : http://stackoverflow.com/questions/17946117/strong-tag-getting-replaced-to-b-tag-in-cq5  and added the nodes as specified. I added the property "b" with value "strong" and property "i" with value "em" to the semanticMarkupMap node. However, I still see <b> on bold text and <i> on Italicized text in RTE.  Has the functionality been changed in AEM 5.6? Is there any more information / documentation available on semanticMarkupMap anywhere? 

I tried adding property "strong" with value "b". After this, The bold text gets wrapped by <b> initially. but on opening source edit, <b> changes to <strong>, On disabling and enabling source edit, it changes back to <b>. It continues to  alternate between strong and b tags.

 

Thanks,

Chaitanya

Accepted Solutions (0)

Answers (1)

Answers (1)

Avatar

Avatar
Coach
MVP
Arun_Patidar
MVP

Likes

1,442 likes

Total Posts

3,322 posts

Correct reply

941 solutions
Top badges earned
Coach
Contributor 2
Ignite 10
Give Back 700
Boost 1000
View profile

Avatar
Coach
MVP
Arun_Patidar
MVP

Likes

1,442 likes

Total Posts

3,322 posts

Correct reply

941 solutions
Top badges earned
Coach
Contributor 2
Ignite 10
Give Back 700
Boost 1000
View profile
Arun_Patidar
MVP

16-02-2021

Adding a comment just in case if someone land here
check http://www.sgaemsolutions.com/2019/10/accessibility-in-aem-bold-vs-strong-and.html