Activation WF - stuck in waiting for activation step

Avatar

Avatar

kimonp31365843

Avatar

kimonp31365843

kimonp31365843

21-10-2020

We are using a customized version of the (out-of-the-box) request for activation workflow. The last few steps are the same as the OOTB flow.

AEM version: 6.5 + SP 6.5.6

 

Expected:

When payload reaches the last steps without any on-time set, it is activated automatically.

 

Actual:

No matter what user (incl. admin) we use to trigger this WF for a page or asset, the WF gets stuck in the step "waiting for activation - Waiting for activation until the scheduled time is reached". This is a participant step assigned to admins.

 

No errors are seen in error.log.

 

Severity/Effect:

This is blocking the activation flow, as only admins would be able to tackle this.

 

Below you can see the last steps of the WF (where it gets stuck) and the Waiting for Activation step config.

 

Screenshot 2020-10-22 at 08.48.12.pngScreenshot 2020-10-22 at 08.48.45.png

 

AEM AEM 6.5.6 workflow workflows

Accepted Solutions (0)

Answers (2)

Answers (2)

Avatar

Avatar

kimonp31365843

Avatar

kimonp31365843

kimonp31365843

22-10-2020

Hi @Sandeep6 and thanks for your reply.

 

The participant step is added out of the box, hence my question; if the workflow is getting stuck there, why is this step indicated as "waiting for scheduled time", implying some automated activation when the ontime is reached?

 

In the meantime I removed the participant step completely, just trying to figure out the OOTB behavior.

Avatar

Avatar

Sandeep6

Avatar

Sandeep6

Sandeep6

22-10-2020

Hi @kimonp31365843 ,

 

In your workflow your adding participant step, which means it is waiting for  approval from user from user group what you have mentioned in that step. Please inform to that person to approve then workflow will complete successfully .

 

Capture.PNG

 

Thanks,

Sandeep.