Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

@Activate method not getting invoked

Avatar

Avatar
Validate 1
Level 2
NaziyaP
Level 2

Like

1 like

Total Posts

21 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Ignite 1
Give Back 5
Give Back 3
Give Back
View profile

Avatar
Validate 1
Level 2
NaziyaP
Level 2

Like

1 like

Total Posts

21 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Ignite 1
Give Back 5
Give Back 3
Give Back
View profile
NaziyaP
Level 2

06-11-2020

Dear All,

We have one service class with one @activate method  which is not getting invoked, But is working fine in other class of the same app. Is there a constraint that only one @activate can be used in one app-core?

 

Thanks in advance

Activate AEM annotations
View Entire Topic

Avatar

Avatar
Validate 10
Level 3
ankurk67503819
Level 3

Likes

15 likes

Total Posts

89 posts

Correct Reply

1 solution
Top badges earned
Validate 10
Validate 1
Boost 10
Boost 5
Boost 3
View profile

Avatar
Validate 10
Level 3
ankurk67503819
Level 3

Likes

15 likes

Total Posts

89 posts

Correct Reply

1 solution
Top badges earned
Validate 10
Validate 1
Boost 10
Boost 5
Boost 3
View profile
ankurk67503819
Level 3

09-11-2020

There is no such constraint

Could you please go to systsem console and inder components tab go to your service and see if it is axtive or not not some refrences are in satisfied state.

If its not active it will not work, try to resolve dependencies.

Hope this helps