ACS commons versioned clientlibs

tahir1601

12-01-2020

Hi All, 

I am implementing versioned clientlibs in my project and came accross the below article

https://adobe-consulting-services.github.io/acs-aem-commons/features/versioned-clientlibs/index.html
The config i place has a 5 level depth unlike 4 level depth mentioned in article.
 Note that the configuration node must be inside a four-level path that ends in config/rewriter.
May I know why this should be 4 level path in order to work. What can be done to make it work on 5 level path.

@arunpatidar26  @antoniom5495929  

ACS Commons Versioned ClientLibs

Accepted Solutions (1)

Accepted Solutions (1)

aemmarc

Employee

13-01-2020

The JCR Installer (by default) only looks 4 levels deep.

 

You need to make an OSGI config change to max.depth to get to the 5th level.

 

aemmarc_0-1578932117928.png

Answers (1)

Answers (1)

Arun_Patidar

MVP

14-01-2020

Hi,

I am not sure why is this restricted but I am just guessing, it may be because of overlay from libs to apps 

/libs/cq/config/rewriter/default 

/apps/myapp/config/rewriter/versioned-clientlibs

Since there is no specific node type to define rewriter, so it could be a path which used to look for all the rewrite configs.

 

There may be another reasons as well.