Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

ACS commons/Marketo + AEM integration: Marketo form not displaying in publisher/dispatcher

Avatar

Avatar
Validate 25
Level 4
jayv25585659
Level 4

Likes

46 likes

Total Posts

117 posts

Correct Reply

0 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Contributor 2
Ignite 5
View profile

Avatar
Validate 25
Level 4
jayv25585659
Level 4

Likes

46 likes

Total Posts

117 posts

Correct Reply

0 solutions
Top badges earned
Validate 25
Validate 10
Validate 1
Contributor 2
Ignite 5
View profile
jayv25585659
Level 4

26-04-2021

So I'm using this ACS commons feature (https://adobe-consulting-services.github.io/acs-aem-commons/features/marketo-form/index.html) to auto-configure the "embed" component for Marketo. This is working fine in author. I can see the marketo form in edit-mode and view-as-published.

I cannot see the marketo form when:

  1. viewing the page/form via the dispatcher
  2. viewing the page/form in the publisher using edit-mode or view-as-published

Any ideas on how to fix? Thanks
EDIT:

After more investigation, I found this code as part of ACS commons

<sly data-sly-use.configMgr="com.adobe.acs.commons.marketo.MarketoClientConfigurationManager" data-sly-use.marketoForm="com.adobe.acs.commons.marketo.MarketoForm">

configMgr is returning blank/null on the publisher BUT it's returning the correct values in author.

In both author and publisher, Marketo has been configured via settings => Cloud services => Marketo. Any more ideas?

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar
Affirm 100
Level 10
asutosh_jena
Level 10

Likes

373 likes

Total Posts

480 posts

Correct Reply

133 solutions
Top badges earned
Affirm 100
Ignite 1
Establish
Give Back 50
Give Back 5
View profile

Avatar
Affirm 100
Level 10
asutosh_jena
Level 10

Likes

373 likes

Total Posts

480 posts

Correct Reply

133 solutions
Top badges earned
Affirm 100
Ignite 1
Establish
Give Back 50
Give Back 5
View profile
asutosh_jena
Level 10

27-04-2021

Hi @jayv25585659 

 

Please make sure the chnages that you have made on author along with the code and content package is deployed to publish instance. Once it is available on publish instance, you should be able to see it on publish as well followed by dispatcher.

 

Thanks!

Answers (0)