Accessing container path in classic UI dialog listener.

Avatar

Avatar

prachiz

Avatar

prachiz

prachiz

25-05-2020

Hi,

 

I have classic UI dialog with xtype selection and selectionchanged listeners. container, box and value parameters are passed to the listener.

When I try to get the container path using container.path, I get value undefined but I'm able to get the path value using dialog.path.
In the same dialog. I have xtype multifield and I'm able to get the path using container.path.

Is there any documentation on how many such out of the box parameters are available for listeners? 

Thanks in advance!

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar

Ravi_Pampana

MVP

Avatar

Ravi_Pampana

MVP

Ravi_Pampana
MVP

25-05-2020

Hi

 

You can find the extjs listeners/events in below link

 

https://docs.sencha.com/extjs/6.2.0/modern/Ext.field.Select.html

Screen Shot 2020-05-25 at 10.13.46 AM.png

Answers (3)

Answers (3)

Avatar

Avatar

aemmarc

Employee

Avatar

aemmarc

Employee

aemmarc
Employee

25-05-2020

You should probably move away from ExtJS use in AEM. It's been in a deprecated state for several years / major releases.

Avatar

Avatar

Veena_Vikram

MVP

Avatar

Veena_Vikram

MVP

Veena_Vikram
MVP

25-05-2020

@prachiz Apologies 😐. I couldn't be of much help here. as I mentioned din reply its been quite a long time I am out of touch with xtypes and classic UI . Hope you get help soon. 

 

Also a recommendation, put a note to your architects or business leads to get the dialog converted to Touch UI. If you are using HTL with Sling models , then you might not have much work to do there , but else if your code is also in JSP, then you might have a bit more work, but trust me it is worth the effort ✌ 

Avatar

Avatar

Veena_Vikram

MVP

Avatar

Veena_Vikram

MVP

Veena_Vikram
MVP

25-05-2020

@prachiz What version of AEM are you using ? agree with @aemmarc . Unless you are using any version which doesn't support Touch UI ( I don't think that should be the case as most of the older version prior to 6.3 should be out of support now )