Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

6.3 Image Upload through Dialog - Validation doesn't work

Avatar

Level 3

Hi All,

I am using the image upload in the dialog and I have added the required property and set it to true. But it doesn't seem to work. My configuration is as below.

Screen Shot 2018-03-13 at 9.13.33 AM.png

Firstly, when the dialog is opened - I can see the star mark coming against the feild Label but when I save the dialog, validation is not getting triggered and the dialog is accepting with out any image.

Secondly, When I drop an image into the image field, then it shows the validation message as shown below.

Screen Shot 2018-03-13 at 9.19.03 AM.png

Are these defects in 6.3? Any help is greatly appreciated.

8 Replies

Avatar

Level 8

I am not able to reproduce the issue. Its working fine with required true property. Its not allowing me to submit without adding image.

Please check all the properties again. You seem to have created a custom component. Please share the code package to test.

1441096_pastedImage_0.png

Avatar

Level 3

Thanks Hemanth. Could you please paste your CRX Structure screenshot please?

Avatar

Level 3

Hi Hemanth,

I have added the property to OOTB V1 component, it doesn;t work in OOTB and We Retail also.

Avatar

Level 8

i see some issue with the required property.  looking for a possible solution

on adding the required property , validation works but when i drag drop a new image, i am not able to submit the dialog

Avatar

Level 3

For me validation never triggered first of all.

Avatar

Level 1

Hi Hemant,

We have been facing same issue. Did you get a chance to look at the issue?

Thanks