Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

6.2 unresolved bundles

Avatar

Avatar
Level 2
lebom50735824
Level 2

Likes

0 likes

Total Posts

17 posts

Correct Reply

0 solutions
View profile

Avatar
Level 2
lebom50735824
Level 2

Likes

0 likes

Total Posts

17 posts

Correct Reply

0 solutions
View profile
lebom50735824
Level 2

20-02-2017

Hi,

I've just installed AEM 6.2 in our environment and installed an AEM 6.1 package on it. I using the Uber APIs but the following can't resolve :

com.day.cq.commons,version=[6.0,7) -- Cannot be resolved
com.day.cq.commons.date,version=[5.7,6) -- Cannot be resolved
com.day.cq.commons.inherit,version=[5.7,6) -- Cannot be resolved
com.day.cq.commons.jcr,version=[6.0,7) -- Cannot be resolved
com.day.cq.commons.mail,version=[5.7,6) -- Cannot be resolved

Any idea on how to resolve these?

lebom

Replies

Avatar

Avatar
Springboard
Level 7
Prince_Shivhare
Level 7

Likes

112 likes

Total Posts

394 posts

Correct Reply

64 solutions
Top badges earned
Springboard
Establish
Give Back 100
Boost 100
Validate 1
View profile

Avatar
Springboard
Level 7
Prince_Shivhare
Level 7

Likes

112 likes

Total Posts

394 posts

Correct Reply

64 solutions
Top badges earned
Springboard
Establish
Give Back 100
Boost 100
Validate 1
View profile
Prince_Shivhare
Level 7

22-02-2017

Hey,

I tried it at my end and I was getting the build success.

I haven't added the jar file manually. also I was checking the resolution in Github and got this:

https://github.com/Adobe-Consulting-Services/lazybones-aem-templates/issues/8

 

~ Prince

Avatar

Avatar
Level 2
lebom50735824
Level 2

Likes

0 likes

Total Posts

17 posts

Correct Reply

0 solutions
View profile

Avatar
Level 2
lebom50735824
Level 2

Likes

0 likes

Total Posts

17 posts

Correct Reply

0 solutions
View profile
lebom50735824
Level 2

24-02-2017

Hi,

I managed to get the code to build with 

main

<dependency>
                <groupId>com.adobe.aem</groupId>
                <artifactId>uber-jar</artifactId>
                <version>6.2.0-SP1</version>
                <!-- classifier>nonobfuscated-apis</classifier -->
                <scope>provided</scope>
            </dependency>

core

<dependency>
            <groupId>com.adobe.aem</groupId>
            <artifactId>uber-jar</artifactId>
            <version>6.2.0-SP1</version>
            <classifier>apis</classifier>
            <scope>provided</scope>
        </dependency>

ui

no 6.2 dependency

After that I installed our main bundle successfully. Then I installed our main package but after installing the package, the file structure that starts with / doesn't appear. Only the / appears. In our production application this structure is something like :

/

  apps

  bin

  content

  etc

In the log file I see the exception "24.02.2017 10:35:06.517 *ERROR* [10.5.2.97 [1487925306517] GET /crx/packmgr/installstatus.jsp HTTP/1.1] org.apache.sling.engine.impl.SlingRequestProcessorImpl ServletResolver service missing, cannot ser
vice requests , sending status 503"

Is this the reason the application structure is not created after installing main package?