404 errors in console for rte.min.js and widgets.min.js in AEM 6.5 after migration

Avatar

Avatar
Level 1
abhishekg583959
Level 1

Likes

0 likes

Total Posts

2 posts

Correct reply

0 solutions
View profile

Avatar
Level 1
abhishekg583959
Level 1

Likes

0 likes

Total Posts

2 posts

Correct reply

0 solutions
View profile
abhishekg583959
Level 1

27-04-2020

We are getting 404 errors for rte.min.js, default.min.js and widget.js after migration from AEM 6.2 to AEM 6.5. We are getting this error only in dispatcher so we tried allowing these filters in publish_filters.any file and the occurences of errors reduced but we can still see some errors related to rte.min.js and we got reference error for widgets.min.js. Attaching the screenshot for reference:

Before dispatcher changes:

abhishekg583959_0-1587993859714.png

After including filters in dispatcher "/libs/cq/ui/*" & "/libs/cq/searchpromote/*"

 

abhishekg583959_1-1587994195035.png

Can someone please give any pointers on how we can resolve this issue?

 

Thanks & Regards,

Abhishek

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar
Boost 5
Employee
tanyakapila
Employee

Likes

9 likes

Total Posts

13 posts

Correct reply

3 solutions
Top badges earned
Boost 5
Boost 3
Boost 1
Applaud 5
Affirm 3
View profile

Avatar
Boost 5
Employee
tanyakapila
Employee

Likes

9 likes

Total Posts

13 posts

Correct reply

3 solutions
Top badges earned
Boost 5
Boost 3
Boost 1
Applaud 5
Affirm 3
View profile
tanyakapila
Employee

27-04-2020

Hi Abhishek,

 

As initial diagnoses , could you confirm what is the js minification compiler ? I hope it is GCC. If not , please follow the below steps.

 

1- Open the "Adobe Granite HTML Library Manager" and set the JS processor configuration to "min:gcc;" to use Google Closure compiler.
2- Open the URL "http://localhost:45010/libs/granite/ui/content/dumplibs.rebuild.html".
3- Click on "Invalidate Cache".
4- Click "Rebuild libraries".

Answers (0)