Very odd bug in DPS 2015

Davd_Spivak_-_A

10-07-2015

I've uploaded a 50+ page Article to a Collection - and I have the Collection Open Default set to Browse Page. I have 5 Collections to my default Collection. Some have content, some don't. They're all set to Browse Page. I go to the option to choose "Current Issue" which is my 50+ page article and I'm taken to the cover of the issue but cannot view the rest of the Article. I know the Article is 50+ pages because I just exported the .article file from the InDesign file 15 minutes ago. So I figure it's a bug with the Browse Page and set all of the Collections to content view. Same result. I unpublish all of my collections to make sure everything is ok, and nothing has changed in the app. I have no content published and I'm able to see everything I just saw when all 5 Collections were published. I close the app on my iPad and re-open it and I'm getting the same result. Nothing is updating. Any assistance would be greatly appreciated.

Accepted Solutions (0)

Answers (5)

Answers (5)

Neil_Enns_-_Ado

Employee

12-07-2015

Ah. You're testing on iOS, right? I think the open to part might be by design, I'll have to chat with Nate on Monday, but we've generally held that the open to setting only applies when a reader actually taps on a card. That philosophy simplified a ton of edge cases. Having said that, I vaguely recall we fixed a bug around this on iOS. I'll have to check.

The 50 page thing is weird. Can you configure your project again so it replicates both issues and then add me as a user with both App Building and Content view/edit rights? neile at adobe.com.

Thanks,

Neil

Davd_Spivak_-_A

12-07-2015

Hi Neil - thanks for the response. Let me try to communicate again what my problem was. First, that blank item doesn't belong below the Top level collection. Second, it doesn't matter what I chose when I asked for Browse Page or Content View for the Collections under the Default Collection - it would always open up to Browse Page.

So I'd have:

Default Collection -> Collection 1 -> Article 1, Article 2, Article 3, etc.

Default Collection -> Collection 2 -> Articles

Default Collection -> Collection 3 -> Articles

Default Collection -> Collection 4 -> Articles

Default Collection -> Collection 5 -> Articles

Collections 1-5 were given the Content View options - yet the app opened up to Browse Page. If I chose Browse Page, they would also open up to Browse Page. Also, if I submitted an article over 50 pages, to a sub-collection (i.e. 1-5), only the first page of the article file would actually show.

I can add collections again to the Top Level Collection and articles to those collections and then show you the results of this.

Neil_Enns_-_Ado

Employee

11-07-2015

Hi David,

That collection is the top-level collection. It drives the menu and the set of things the reader can swipe left/right through at the top level of your app. You never actually see a browse page for it.

If you want to show a browse page when your app starts up you need to put another collection inside the default top-level collection. I typically give that collection the long title of my app (e.g. "Adobe Inspire") and a short title of "Home". That way it shows up as Home in the menu, but as the app name in the header.

Colin has a good video that walks through this. You can find it at Manage Collections - Adobe Digital Publishing Solution - YouTube. He starts talking about building a "Home" (he calls it Launch) collection at 9:19 and the top-level collection at 13:23.

Neil

Davd_Spivak_-_A

11-07-2015

Update on my bug: I've removed every single layout, every single card, every single collection (except default) and every single article. No matter what, when my default collection is set to Browse Page or Content View, it still gives me browse page. I've done everything -- don't know why this is happening.

Also, even more oddly, I have a completely blank article under my default collection. I cannot select it. I cannot delete it. It's kind of just there and not going away.

Screen Shot 2015-07-11 at 9.11.01 PM.png