Nested MSO not appearing in web viewer

Avatar

Avatar

IDEXX_AEM_Mobil

Avatar

IDEXX_AEM_Mobil

IDEXX_AEM_Mobil

17-06-2016

Hello,

We have a few AEM Mobile articles that use the unsupported 'nested MSO' trick from the DPS Learn app. These still work and appear great in the app version, however they are not rendering correctly in the web viewer. The nested content seems to be blank or just covers a portion of the screen and does not have any interactivity.

Has anyone else come across this? Any work arounds? or do i just need to ditch using the nested MSO trick?

thanks!

Accepted Solutions (0)

Answers (5)

Answers (5)

Avatar

Avatar

BobLevine

Avatar

BobLevine

BobLevine

17-06-2016

Thanks Bob. Saves some troubleshooting time.

Avatar

Avatar

BobLevine

Avatar

BobLevine

BobLevine

17-06-2016

Did you convert the nested MSO or the entire MSO to HTML with in5

Avatar

Avatar

Bob_Bringhurst_

Employee

Avatar

Bob_Bringhurst_

Employee

Bob_Bringhurst_
Employee

17-06-2016

Right, the nested overlay example that I used in the DPS Learn app doesn't work in web viewer at this time. I let the team know about this issue.

Avatar

Avatar

IDEXX_AEM_Mobil

Avatar

IDEXX_AEM_Mobil

IDEXX_AEM_Mobil

17-06-2016

Bob, thank you for the suggestion. The nested portions of the MSO do not seem to render in the IN5 html file. I may need to just rethink a few of these articles and not use the unsupported Nested MSO any more.

Avatar

Avatar

BobLevine

Avatar

BobLevine

BobLevine

17-06-2016

I won’t even pretend to know about how the web viewer renders this but you could try to convert it to a web content overlay using in5, if you have it.