Lag time updating Preflight?

Avatar

Avatar
Validate 1
Level 1
jclayto
Level 1

Likes

0 likes

Total Posts

9 posts

Correct reply

0 solutions
Top badges earned
Validate 1
View profile

Avatar
Validate 1
Level 1
jclayto
Level 1

Likes

0 likes

Total Posts

9 posts

Correct reply

0 solutions
Top badges earned
Validate 1
View profile
jclayto
Level 1

16-03-2016

Is anyone else seeing substantial lag time between after making a change (replacing an article with updated file etc) and seeing the update appear in the preflight android app? I am remembering to click the pre-flight button for the project after making changes.

Accepted Solutions (0)

Answers (5)

Answers (5)

Avatar

Avatar
Validate 1
Level 1
jclayto
Level 1

Likes

0 likes

Total Posts

9 posts

Correct reply

0 solutions
Top badges earned
Validate 1
View profile

Avatar
Validate 1
Level 1
jclayto
Level 1

Likes

0 likes

Total Posts

9 posts

Correct reply

0 solutions
Top badges earned
Validate 1
View profile
jclayto
Level 1

18-03-2016

Hi Christophe,

After clearing the cache all projects loaded as expected. Thanks for the workaround! If it helps with your troubleshooting I am on a Verizon Samsung Galaxy s5 sm-g900v running Android 5.0.

Avatar

Avatar
Validate 1
Level 1
jclayto
Level 1

Likes

0 likes

Total Posts

9 posts

Correct reply

0 solutions
Top badges earned
Validate 1
View profile

Avatar
Validate 1
Level 1
jclayto
Level 1

Likes

0 likes

Total Posts

9 posts

Correct reply

0 solutions
Top badges earned
Validate 1
View profile
jclayto
Level 1

18-03-2016

Thank you, I will give that a shot. 

The changes that I made on the morning of the 16th finally appeared in my preflight app yesterday afternoon without any further intervention from me. I will try clearing the cache on my device between updates.

Avatar

Avatar
Give Back 10
Employee
Christophe_Joss
Employee

Likes

56 likes

Total Posts

241 posts

Correct reply

67 solutions
Top badges earned
Give Back 10
Give Back 5
Give Back 3
Give Back
Publish 1
View profile

Avatar
Give Back 10
Employee
Christophe_Joss
Employee

Likes

56 likes

Total Posts

241 posts

Correct reply

67 solutions
Top badges earned
Give Back 10
Give Back 5
Give Back 3
Give Back
Publish 1
View profile
Christophe_Joss
Employee

18-03-2016

For testing purposes, can you try and go to your device settings, select your App and enable 'Clear Content' to clear the cache. Then restart your App and see if it does trigger a change.

Avatar

Avatar
Validate 1
Level 1
jclayto
Level 1

Likes

0 likes

Total Posts

9 posts

Correct reply

0 solutions
Top badges earned
Validate 1
View profile

Avatar
Validate 1
Level 1
jclayto
Level 1

Likes

0 likes

Total Posts

9 posts

Correct reply

0 solutions
Top badges earned
Validate 1
View profile
jclayto
Level 1

17-03-2016

Thank you for taking time to test. I am indeed on the latest release of the AEM app.  I am sure the issue I am having results from my lack of experience with the product.  For example, I have a simple project that I have created that consist of one article content file with the default collection containing that article. The content file is a single page html from Muse that was converted to article format. When launching the project in preflight it loads as expected displaying the article page. The problem comes when I need to update that article file. I go back to muse, make changes to the file, re-export the html, repackage as an article and re-upload the article file by clicking on the original article and replacing the content file. I then click the pre-flight button and wait for the process to finish. The changes to the project never appear in preflight. It seems like the app caches the original project the first time I open it and it will not update the view.

On a second project,I have deleted all content in the project yet it still loads as if the content is there in the preflight app.

I am very new to DPS/AEM so I feel certain it has to be something I am doing incorrectly.

Avatar

Avatar
Give Back 10
Employee
Christophe_Joss
Employee

Likes

56 likes

Total Posts

241 posts

Correct reply

67 solutions
Top badges earned
Give Back 10
Give Back 5
Give Back 3
Give Back
Publish 1
View profile

Avatar
Give Back 10
Employee
Christophe_Joss
Employee

Likes

56 likes

Total Posts

241 posts

Correct reply

67 solutions
Top badges earned
Give Back 10
Give Back 5
Give Back 3
Give Back
Publish 1
View profile
Christophe_Joss
Employee

17-03-2016

I have tested a fair bit on Android and it seems to be working ok for me.

Are you using the latest March 8th version: AEM – Mobile Preflight - Android Apps on Google Play     ?