ERROR ITMS-90596: "Invalid Bundle..."

TommyDAQ-Bates

22-12-2016

Received this Error while trying to submit an AEMM App through Application Loader.  Any insight on what is causing this? Built w/ 2016 R14.

ERROR ITMS-90596: "Invalid Bundle. The asset catalog at 'Payload/Jupiter.app/Frameworks/ArticleView.framework/Assets.car' can't be read. Try rebuilding the app with a non-beta version of Xcode and submit it again."

Accepted Solutions (0)

Answers (3)

Answers (3)

TommyDAQ-Bates

22-12-2016

Thank you Grant!  Just to clarify, when you say delete the Xcode files, you mean do a complete uninstall of Xcode? Then, DL and Reinstall? 

Grant_Fritch

22-12-2016

Tommy - Yes, this happened to me as well.  To solve the problem, I had to delete all previous Xcode files, download a fresh copy (takes a bit of time). Then rebuild the App in AEM.  Make sure that you also delete the previous Application Loader and use the new one that comes with the new version of Xcode.  I was able to upload .ipa with no errors.