DPS-App just starts to a white page

Avatar

Avatar

TheCrystalEYE

Avatar

TheCrystalEYE

TheCrystalEYE

18-09-2015

Hey there,

we have been using the "old" DPSuite for about a year now and are testing the DPSolution at the moment.

I have set up a project, migrated an old and perfectly working folio and pusblished all the articles.

I built an app, downloaded and signed it and installed it on my iPad.

Now when I start the app, I can see the splash screen and a loading circle but afterwards the app just goes blank/white and nothing else happens.

I have checked all Apple-Certificates and rebuilt the provisioning file and made sure to include my UDID (read from iTunes).

I tried playing with the top-level collections and articles and rearranging article structure and order.

The behaviour occured both with versions 2015.3 and .4

I found a similar question here in the forum (I have checked all Apple-Certificates)

Any idea where to check for errors?

I don`t know where else to look and our trial is running out 15-09-25

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar

Bob_Bringhurst_

Employee

Avatar

Bob_Bringhurst_

Employee

Bob_Bringhurst_
Employee

18-09-2015

If you get a white screen when you launch the app, try this:

(1) Make sure that you have created a start collection (sometimes called a "home" collection), and add that start collection to your top-level nav collection ("default" or "default tablet"/"default phone").

(2) If you selected "Enable Preview" when building the app, make sure that you click the Preview icon to make all your content available. If you did not select Enable Preview, publish your collections and articles.

(3) If it still doesn't work, try uninstalling and reinstalling the app.

Content fails to appear in app

Answers (2)

Answers (2)

Avatar

Avatar

Bob_Bringhurst

Avatar

Bob_Bringhurst

Bob_Bringhurst

21-09-2015

One option is to build two apps--one with Enable Preview selected and one with it turned off. Another option is to rebuild the app and turn the Enable Preview option on or off depending on whether you're building the preview app or the production app. Both options work well.

Avatar

Avatar

TheCrystalEYE

Avatar

TheCrystalEYE

TheCrystalEYE

21-09-2015

Ah, number 2 did the trick. Thanks a lot.
So, do I get it right that I have to build 2 different apps?

One live app to publish all my content and one preview app for testing unpublished content.

I cannot use the same app to publish content AND preview unfinished stuff at the same time?