dentrix conflic

mariomontoya

25-01-2016

We are encountering problems with our Dentrix software and apparently it's due to an automatic upgrade version.  It's required to run in version 20.0.0.228.  Can you please have this fixed?  Thanks.

Accepted Solutions (0)